Results 1 to 6 of 6
  1. #1
    Join Date
    Jul 2006
    Posts
    228
    Points
    9,274
    Level
    41

    Question proftp error (ftpusers)

    Hi
    since the proftp update i have been getting a lot of this in my logs, i checked and i dont have ftpusers file ?
    i also checked the proftp.config and ftpusers is set to off ?
    Should i create a ftpusers file and i think it contains users you dont want to use ftp, which users should be denied.
    or can i disable the checking.
    Thank you


    pam_listfile(ftp:auth): Couldn't open /etc/ftpusers
    pam_unix(ftp:auth): check pass; user unknown
    pam_unix(ftp:auth): authentication failure; logname= uid=0 euid=0 tty= ruser=ftp@domain.com rhost=##.##.##.##
    Gary T

  2. #2
    Join Date
    Jan 2004
    Location
    Pittsburgh, PA
    Posts
    1,211
    Points
    16,708
    Level
    56
    Hi Gary,

    This error isn't critical and can be safely ignored. It's looking for the /etc/ftpusers file, but it's not needed and InterWorx doesn't use it for ftp user management at all.

    Paul
    Paul Oehler
    InterWorx-CP | http://interworx.com
    InterWorx Control Panel

  3. #3
    Join Date
    Jul 2006
    Posts
    228
    Points
    9,274
    Level
    41
    Ok thanks, how do i disable it from looking for the ftpusers file as on some days
    there are loads of the messages.
    cheers
    Gaz
    Gary T

  4. #4
    Join Date
    May 2013
    Posts
    14
    Points
    1,788
    Level
    17
    Hello,

    it would be nice if you find a way to disable this error, because /var/log/secure is being rotated weekly and getting more than 1 million lines of this errors every week and I think a little change in /etc/pam.d/ftp could probably solve this problem?

    Kind regards,


    Alex

  5. #5
    Join Date
    Apr 2012
    Posts
    2,135
    Points
    22,611
    Level
    65
    Hi arusa

    Many thanks, good idea

    Please could I ask if you have debug set to on, if so, if you disable debug output does this then reduce the entries

    Many thanks

    John

  6. #6
    Join Date
    May 2013
    Posts
    14
    Points
    1,788
    Level
    17
    Thanks, you are right, SysLogLevel "debug" was enabled and I changed it to "info".

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •