Results 1 to 4 of 4
  1. #1
    Join Date
    Jul 2011
    Location
    Sweden
    Posts
    149
    Points
    3,290
    Level
    23

    Joomla 3.0 - php 5.3.x required

    This weekend i tested the new Joomla 3.0 alpha.
    Joomla 3.0 will come as a Beta in July and stable in september.
    And I'm sorry to say, but the new version of Joomla vill require php 5.3.x. What are the plans of uppgrading the client side PHP to 5.3.x or newer? Current php.net stable is 5.4.3.

    MySQL will most probably have to be upgraded as well. I don't have any specific versions for MySQL, but the current stable version on MySQL website is 5.5.24.

    Being able to support Joomla 3.0 is Ciritcal for us, as we are mainly a Joomla host.

  2. #2
    Join Date
    Jun 2011
    Posts
    137
    Points
    1,826
    Level
    17
    It's not actually supported, but if you can find repositories for both php and mySQL that will work with your version of centos and carry the latest version of each, you can just install them. I'm not sure what kind of problems that will cause, though, and as I said we can't give you support for any issues that crop up as yet.

  3. #3
    Join Date
    Sep 2005
    Location
    Texas
    Posts
    396
    Points
    9,923
    Level
    42
    Quote Originally Posted by IWorx-Robert View Post
    It's not actually supported, but if you can find repositories for both php and mySQL that will work with your version of centos and carry the latest version of each, you can just install them. I'm not sure what kind of problems that will cause, though, and as I said we can't give you support for any issues that crop up as yet.
    Any update on this, as 5.2.17 is way past end of life.
    Roy
    KARTHOST.com
    [ KARTHOST Facebook FAN Page ]
    [ Follow KARTHOST on Twitter ]
    WordPress Training - KartHost University

  4. #4
    Join Date
    Aug 2010
    Location
    Pittsburgh, PA
    Posts
    166
    Points
    2,220
    Level
    19
    Hi,

    So the thing is we don't really handle the PHP packages. Mostly because InterWorx is not super dependent on the version of PHP that runs on the server. As long as it's a set of PHP packages built and distributed for the version of RHEL or CentOS you are using, it should integrate just fine with Apache and InterWorx.

    My quick recommendation is to grab something like Atomic Turtle and install that. BEFORE running yum update or yum install anything, refer to this article:

    FAQ: Which packages should I exclude from 3rd-party repos?

    and exclude packages that need to come from the InterWorx repository in the /etc/yum.repos.d/*.repo file that corresponds to atomic turtle. Alternatively, you can leave the repository disabled, and do a:

    Code:
    yum --enablerepo=atomic update php
    everytime you want to update PHP. This will localize the use of the repository to just when you want to update PHP.
    Daniel Motles
    Technical Support
    InterWorx-CP | http://interworx.com/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •