Results 1 to 6 of 6
  1. #1
    Join Date
    Dec 2011
    Posts
    14
    Points
    2,768
    Level
    21

    Externally hosted email (ie exchange)

    I have several customers that don't need nor want email attached to their domain, or their email is hosted elsewhere through another service, like an exchange provider, gmail (yetch) or whatever. I colo a couple of exchange servers for customers as well.

    What would be ideal is to have an account that I can set up with DNS and hosting only.

    Internally, what happens currently is that the system will always look to itself first and find that email records don't exist for all but postmaster and reject.

    Externally I'm finding that there can be other kind of anomalies with regards to how DNS resolution is performed by the CP such as timeouts, can't find host, and email not found. There really isn't a rhyme or reason to how the rejection is determined from a high level overview.

    It's worth noting that I did this with a google docs hosted account. I removed all mail records and had all of google's MX records, CNAMEs and spf records set but still had the oddness above. There simply doesn't be a way to remove "email" from the "package"

  2. #2
    Join Date
    Apr 2012
    Posts
    2,179
    Points
    24,148
    Level
    67
    Hi

    I hope I understand what you've said correctly, apologies if I have not.

    You can set the siteworx account to email is externally handled and so long as your dns records are correct, it should work lovely. We have a lot of clients who are set this way without issues or timeouts on any records served, and there's a mixture of google mail, exchange or smartermail mail servers.

    I think I'm right in thinking that removing email from a package is not required if you set the siteworx account to external but I understand you prefer not to have it shown to client side.

    I hope this helps if you were not aware of it

    Many thanks

    John

  3. #3
    Join Date
    Dec 2011
    Posts
    14
    Points
    2,768
    Level
    21
    I think you got it right, I didn't really explain it all that well.

    I had a client set up that was using google and I had all the MX records in place, etc and had even removed mail.domain.tld DNS but any time I attempted to send email from an account on that server to that domain it would immediately reject the email as email address not found.

    I don't care if the customer sees email options in the CP (though ideally they wouldn't), just that other domains on the same server don't have immediate rejections (MTA won't even accept the email) because of local look-up for email account failing as it doesn't exist on local server.

    Does that make more sense?
    Last edited by webnexus; 06-06-2013 at 03:54 PM.

  4. #4
    Join Date
    Apr 2012
    Posts
    2,179
    Points
    24,148
    Level
    67
    Hi

    Many thanks, please can confirm you have the following set on the domain (siteworx account)

    Administration, mail options, remote setup, local delivery status is set to disabled.

    If not please set it to disabled and retest.

    This option tells interworx that email is handled externally and should look to dns for mx records correctly.

    The last thing I can think of right now is if it doesn't work as expected, are the name servers correctly pointed to you interworx dns and/or are you having any network issues.

    Hope that helps

    Many thanks

    John

  5. #5
    Join Date
    Dec 2011
    Posts
    14
    Points
    2,768
    Level
    21
    Well I'll be! I looked all over the place. I didn't think to look at the customer's access directly. That will probably solve the problem right there!

    Thanks!

  6. #6
    Join Date
    Apr 2012
    Posts
    2,179
    Points
    24,148
    Level
    67
    Hi

    Many thanks, I hope it solves your issues.

    As a side note, if you prefer to have interworx default to external email on new siteworx accounts which are setup, you can set it this way from nodeworx I think from memory, but if you can't find it, please let me know and I'll post the correct actions, but then if you have a client who wants to use email in interworx, you will have to enable it as you do for disabling above to allow this.

    Also, if you have any issues like this, the first I usually do for problem solving is run a dns test on the domain to see what records are served and controlled by which server.

    I'd appreciate if you could post if it corrects the issue or not, and if not, ideally if you want to pm me the proper domain, I'll run some tests to see.

    Many thanks

    John

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •