Results 1 to 4 of 4
  1. #1
    Join Date
    May 2004
    Location
    Miami
    Posts
    1,103
    Points
    14,933
    Level
    53

    Qmail - Allow relay for a specific IP address

    I found a couple web pages, but I still can't get it to relay.
    http://www.qmail.org/qmail-manual-ht...c/FAQ.html#5.4
    http://www.roamer1.org/computing/qmail.html


    The second link is closer to the setup of the RH9 Iworx box because it has the config for using xinetd vs inetd in the first post.

    I tried what it said, but I still get the:
    "553 sorry, that domain isn't allowed to be relayed thru this MTA (#5.7.1)"

    Any other ideas on how to set this up?

    Thanks

    [edit]
    Another Link: http://www.barriebremner.com/qmailxinetd.html
    Last edited by Justec; 06-04-2004 at 10:49 PM.

  2. #2
    Join Date
    Jan 2004
    Location
    Pittsburgh, PA
    Posts
    1,210
    Points
    13,326
    Level
    50
    Hi Justec,

    Sure, just do the following:

    Edit the /etc/tcprules.d/tcp.smtp file
    If the IP address you wanted to allow relaying for was 22.22.22.22, add the following line to this file:
    22.22.22.22:allow,RELAYCLIENT=""
    Then,
    cd /etc/tcprules.d/
    tcprules tcp.smtp.cdb tcp.smtp.temp < tcp.smtp
    That should do it,

    Paul

  3. #3
    Join Date
    May 2004
    Location
    Miami
    Posts
    1,103
    Points
    14,933
    Level
    53
    Hi Paul,

    So the interworx setup already has the tcpserver installed.

    Wasn't sure how that worked if you have TCPserver and xinetd installed and running simultaneously.

    Going to try it now, I'll let you know if it still doesn't work.

    Thanks,
    Justin

    EDIT - Works Great, Thanks again
    Last edited by Justec; 06-05-2004 at 12:32 AM.

  4. #4
    Join Date
    May 2004
    Location
    Miami
    Posts
    1,103
    Points
    14,933
    Level
    53
    Woah, this is an old one. Just wondering if there is some other way to do this now? I tried these steps on a new server I just moved to, but it's still rejecting my email.

    Nevermind, just had to manaully edit /service/smtp/run from:


    export FORCE_TLS=1
    export DENY_TLS=0
    export REQUIRE_AUTH=1
    export ALLOW_INSECURE_AUTH=0

    to

    export FORCE_TLS=0
    export DENY_TLS=0
    export REQUIRE_AUTH=0
    export ALLOW_INSECURE_AUTH=1
    Last edited by Justec; 07-28-2010 at 06:30 PM.
    [ JUSTIN ]
    [ OFF unit ]
    [ WEB DESIGN / DEVELOPMENT, GRAPHIC DESIGN, OTHER STUFF
    ]

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •