Page 2 of 2 FirstFirst 12
Results 16 to 22 of 22
  1. #16
    Join Date
    Jan 2015
    Posts
    3
    Points
    547
    Level
    8
    Just come across this issue on a fresh centos 6.6 install. Any ideas on how to fix this as due to my setup the server cant be accessed externally via ip (which i think the support team will ask for)

    Centos6.6
    Interworx CP v5.0.15
    mysql-5.1.73-3.el6_5.x86_64 already installed and latest version
    Last edited by mhudson324; 01-16-2015 at 05:10 PM.

  2. #17
    Join Date
    Apr 2012
    Posts
    2,179
    Points
    24,164
    Level
    67
    Hi mhudson

    I don't think it can be corrected without ssh access.

    I know IW have included this in their meetings and will correct it so it installs correctly first time as it should.

    If you prefer to attempt yourself and you have ssh access, you need to add into my.cnf the part for hash=1, sorry, it's late here and I'll need to lookup the exact line, which is missing.

    Then you need to rehash the password and restart MySQL

    That then should restore service.

    If however, you have ssh access, then you would be best advised to open a support ticket with IW and let them correct the issue. If you have any doubts over security, the remote support means they don't use your access credentials.

    I hope that helps

    Many thanks

    John

  3. #18
    Join Date
    Jan 2015
    Posts
    3
    Points
    547
    Level
    8
    John thanks for the prompt response.

    I had a feeling you would say that SSH is required for the support team to fix it. Unfortunately its not possible for them to SSH onto my server as its behind a secure firewall etc.

    If you could provide the exact line i need to add i'm more than happy to try and sort it myself (and it may help others in the same situation)

    I appreciate that timezones make things more fun so im more than happy to wait until you can make a reply. Unlikely to have the time to work on changing the set up until monday anyway

  4. #19
    Join Date
    Apr 2012
    Posts
    2,179
    Points
    24,164
    Level
    67
    Hi Mhudson
    Many thanks, but I can assure IW are genuine and would not cause any issues, and to be sure you could change your passwords, before and after.
    I understand the need for security, but as with everything, you have to trust some people.
    In any event, please see below for how to correct, but if you cannot manage it, please open a support a ticket with IW. Honestly, those guys rock, and they have access to all our systems/servers, and we are a secure company (well, as much as anyone can say anyway), and our clients are a mixture of blue chip, educational and everywhere inbetween.
    I hope that helps a little
    Many thanks
    John
    old_passwords=1 was missing from /etc/my.cnf. I added it and skip-grant-tables and rehashed the password. I then removed skip-grant-tables and restarted mysqld

  5. The Following 2 Users Say Thank You to d2d4j For This Useful Post:


  6. #20
    Join Date
    Jan 2015
    Posts
    3
    Points
    547
    Level
    8
    d2d4j have a solution working. IW CP still refused to communicate to mysql on localhost but setting up a remote server directed back to itself on 172.16.0.100 worked fine after following your sugestions.

    Its not that i dont want to let IW access the server. its the fact that its physically not possible with the combination of a dynamic public ip, firewalls and virtual machines.
    Because its a dev environment its a total mess Thanks for your help, you got me working ahead. hopefully by the time im happy with the site and setup they will have fixed the issue so i can smoothly move to a production enviroment

  7. The Following User Says Thank You to mhudson324 For This Useful Post:


  8. #21
    Join Date
    May 2010
    Posts
    193
    Points
    8,360
    Level
    39
    Quote Originally Posted by d2d4j View Post
    old_passwords=1 was missing from /etc/my.cnf. I added it and skip-grant-tables and rehashed the password. I then removed skip-grant-tables and restarted mysqld
    Thank you John, this was the working solution!

  9. The Following User Says Thank You to dss For This Useful Post:


  10. #22
    Join Date
    Apr 2012
    Posts
    2,179
    Points
    24,164
    Level
    67
    Hi mhudson

    Many thanks, I'm sure IW will ready be in process of fully correcting this issue, so I hope by the time you go full production, it should be good.

    I'm not sure why localhost would not work, thinking it might be connected with host file, or perhaps your setup is blocking.

    Glad your up and running, and hope you enjoy IW.

    The fix came from IW, so kudos to the guys, they rock

    Many thanks

    John

  11. The Following User Says Thank You to d2d4j For This Useful Post:

    dss

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •