Page 1 of 2 12 LastLast
Results 1 to 15 of 22
  1. #1
    Join Date
    Jul 2014
    Posts
    9
    Points
    1,225
    Level
    13

    Unhappy problems with V5.0.15 fresh install

    Hello guys
    I changed my server and tried to install a fresh version of interworx . Now i have big problems in a fresh CENTOS6.5 ınterworx 5.0.15 install .
    First of all after installation and entering license key i got :
    "replyCode: 500replyText: Generic Server Issue
    replyData:
    null"

    after i log in to panel , system graphs are not working . (image attached)
    Name:  i1.jpg
Views: 287
Size:  48.1 KB

    Name:  i3.jpg
Views: 277
Size:  43.6 KB
    when i try to import a backup file i got error :
    "B Error: connect failed [nativecode=Client does not support authentication protocol requested by server; consider upgrading MySQL client] ** mysql://iworx:xxxxxxxxxx@unix(/var/lib/mysql/mysql.sock)/mysql"

    and when i go into mysql server page it just looks like running but no version information or settings available
    Name:  i2.jpg
Views: 281
Size:  47.8 KB

    What is wrong with interworx new installs ??? how can i install older versions of interworx ? im dealing with this for two days , websites are down and people are pissed off !!! help me urgent plzz
    all i did install a fresh interworx on a fresh centos 64 bit v6.5, and change the status of ip to shared and try to import backup .

    Thanks

  2. #2
    Join Date
    May 2010
    Posts
    193
    Points
    8,360
    Level
    39
    This solution can solve the mysql problem: http://forums.interworx.com/threads/...6900#post26900

    After fixing the mysql problem my graphs started to work. I don't know why

  3. The Following 2 Users Say Thank You to dss For This Useful Post:


  4. #3
    Join Date
    Jul 2014
    Posts
    9
    Points
    1,225
    Level
    13
    i am still not sure how to fix it , any step by step solution on this?

  5. #4
    Join Date
    Apr 2012
    Posts
    2,179
    Points
    24,207
    Level
    68
    Hi cartman10mpi

    If your not too sure I would open a support ticket with IW (nodeworx, remote support) and let IW correct it for you.

    If you do, please ensure you turn on remote access and include in the ticket that remote access has been enabled. It will auto disable in 24 hours.

    I hope that helps

    Many thanks

    John

  6. #5
    Join Date
    Jul 2014
    Posts
    9
    Points
    1,225
    Level
    13
    i got the license from licensecart and as far as i know if the license is not directly from interworx , the support will not help me with it , i guess i need to contact licensecart support for this and again i am not sure when they will reply , i need to get this fixed fast

  7. #6
    Join Date
    Apr 2012
    Posts
    2,179
    Points
    24,207
    Level
    68
    Hi cartman10mpi

    Mikes truly great with IW but as this is an IW install issue, I'm thinking they'll correct it.

    If you open an IW support ticket directly, please ensure you include this post.

    If you open a ticket with licensecart, again please include this ticket but I know mike reads this forum regularly.

    Please note though, if you need support for other issues, you would be best advised to go through licensecart, as it would not be an install failure due to IW.

    I hope that helps

    Many thanks

    John

  8. The Following User Says Thank You to d2d4j For This Useful Post:


  9. #7
    Join Date
    May 2010
    Posts
    193
    Points
    8,360
    Level
    39
    This is John's solution how I made. But as John wrote, if you are not too sure better to open a support ticket! If you want to do yourself, make backup!

    1. Open iworx.ini file and check [mysql] section, there is the mysql password in rootdsn line (rootdsn="mysql://iworx:XXXXXXXXXXX@unix(/var/lib/mysql/mysql.sock)/mysql"). XXXXXXXXXXX is your password
    2. Open my.cnf file and append the following lines to [mysqld] section: old_passwords=1 and skip-grant-tables
    3. Restart mysql
    4. mysql -u root
    5A. UPDATE mysql.user SET Password=PASSWORD('XXXXXXXXXXX') WHERE User='iworx';
    5B. quit
    6. Change mysql root password in NodeWorx
    7. Remove skip-grant-tables from my.cnf
    8. Restart mysql

  10. The Following 2 Users Say Thank You to dss For This Useful Post:


  11. #8
    Join Date
    Apr 2012
    Posts
    2,179
    Points
    24,207
    Level
    68
    Hi dss

    That's a lovely post, detailing precisely what's needed.

    I wish I had wrote that but I'm on tapatalk from mobile, still onsite a clients, and not infront of pc, but doing things from memory

    Many thanks for sharing

    John

  12. The Following User Says Thank You to d2d4j For This Useful Post:


  13. #9
    Join Date
    Jul 2014
    Posts
    9
    Points
    1,225
    Level
    13
    Thank you very much guys , I did the step by Step guide and it works now , everything looks normal . I will start importing websites now .

    I really love interworx and its community , having you guys is awesome . THANK YOU

  14. #10
    Join Date
    May 2010
    Posts
    193
    Points
    8,360
    Level
    39
    You're welcome! Are the graphs working good after fixing mysql? What about the activation problem? Did you remove skip-grant-tables option? It's very important!
    Last edited by dss; 01-17-2015 at 12:37 PM.

  15. #11
    Join Date
    Jul 2014
    Posts
    9
    Points
    1,225
    Level
    13
    yes the graphs now working and i can successfully import websites , i already passed the activation so i am not sure if it is fixed or not . i removed the skip-grant-tables as you advised but old_passwords=1 is still there in config file .

  16. #12
    Join Date
    Apr 2012
    Posts
    2,179
    Points
    24,207
    Level
    68
    Hi dss and cartman10mpi

    The graphs data is held in the MySQL I believe, so I would expect it to start showing as expected.

    The old password =1 is required, remember there are 2 MySQL versions installed, 1 for IW (ver4) and 1 for hosing (ver 5). If you remove or change old password to 0, then you will encounter issues due to hashing difference. This is not insurmountable but unless you understand the differences, may stop you for a while.

    Glad it's all working now and welcome to the forums, there's a good crowd here who are knowledgable and like to help where we can

    Many thanks

    John

  17. The Following User Says Thank You to d2d4j For This Useful Post:

    dss

  18. #13
    Join Date
    May 2010
    Posts
    193
    Points
    8,360
    Level
    39
    It's OK! the old_passwords parameter is required with this version of IW. The new version will handle the new mysql password hash as I see.

  19. The Following User Says Thank You to dss For This Useful Post:


  20. #14
    Join Date
    Apr 2012
    Posts
    2,179
    Points
    24,207
    Level
    68
    Hi dss

    That's excellent news, good to hear.

    Do you mind checking if both MySQL are ver 5 on centos 7

    Appreciate it when you have time

    Many thanks

    John

  21. #15
    Join Date
    May 2010
    Posts
    193
    Points
    8,360
    Level
    39
    Yes, I checked.


    The current version uses: 5.1.73 for hosting and 4.0.21 for IW
    The alpha uses: 5.5.40 MariaDB for hosting and 5.5.30 (iworx-db-55, I don't know what kind of server is it exactly, I didn't check) for IW, both using new hash algorithm

  22. The Following User Says Thank You to dss For This Useful Post:


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •