Results 1 to 4 of 4
  1. #1
    Join Date
    Mar 2014
    Posts
    74
    Points
    3,484
    Level
    24

    Exclamation Default MySQL Settings Causes Errors

    The default of the mysql packet setting causes site import and table import errors. Please reference this post: http://forums.interworx.com/threads/...8572#post28572

    Very easy fix.

    Edit: Please excuse the terrible grammar of the thread title. Was in a hurry.

  2. #2
    Join Date
    Mar 2014
    Posts
    74
    Points
    3,484
    Level
    24
    Correction. While this change of default value should still be done because it does prevent proper imports, there is still a bug in the backup import process for cpanel backups. I just ran a multi-import and none of the databases from the other server were brought in.

    edit: Now I really do have to do all sql manually. meh.
    Last edited by Synthetisoft; 06-03-2016 at 03:17 AM.

  3. #3
    Join Date
    Apr 2012
    Posts
    2,187
    Points
    24,755
    Level
    68
    Hi synthetisoft

    Great posts and good catch

    I would still open a support ticket with IW to let them have a look as cpanel import is very important to them that it works

    Trying to resolve by yourself is good, but hopefully you would share with IW your particular issue/resolution

    It is important to remember that with IW, every server is different, some with large resources and some with low resources, so the default settings are most likely to be set towards the lower resource server (also consider some will use a separate MySQL server but most would use MySQL on the same server).

    I see you set your max packet to 256mb, wow but guess you do a lot on word press perhaps

    Please do not misunderstand my post, I am not having a go at you, and thank you for your excellent helpful posts, kudos to you

    Many thanks

    John

  4. #4
    Join Date
    Mar 2014
    Posts
    74
    Points
    3,484
    Level
    24
    Quote Originally Posted by d2d4j View Post
    Hi synthetisoft

    Great posts and good catch

    I would still open a support ticket with IW to let them have a look as cpanel import is very important to them that it works

    Trying to resolve by yourself is good, but hopefully you would share with IW your particular issue/resolution

    It is important to remember that with IW, every server is different, some with large resources and some with low resources, so the default settings are most likely to be set towards the lower resource server (also consider some will use a separate MySQL server but most would use MySQL on the same server).

    I see you set your max packet to 256mb, wow but guess you do a lot on word press perhaps

    Please do not misunderstand my post, I am not having a go at you, and thank you for your excellent helpful posts, kudos to you

    Many thanks

    John
    No offense taken. I have some custom databases that are several gigs. I'm not sure what the packet setting value should be but 256MB worked for a database of over a gig so it should work for a db of any size. I'll open a ticket about the imports. I ran an import for 13 accounts and not one database or sql user was imported. I think the single account import might still work. I've also noticed that some superfluous DNS records get imported from CPanel.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •