Page 2 of 2 FirstFirst 12
Results 16 to 29 of 29

Thread: Bulk TTL Update

  1. #16
    Join Date
    Jul 2016
    Posts
    16
    Points
    645
    Level
    9
    Thanks for your reply,

    I have new server with different kernel and system installed 3 days ago,

    Name:  Screenshot_362.png
Views: 63
Size:  36.8 KB

    But iworx db also not showing.

    Maybe I need open support ticket now,

    Thanks!

  2. #17
    Join Date
    Jul 2006
    Posts
    228
    Points
    9,274
    Level
    41
    I was just reading this thread and I don't have iworx db showing either, it did not show on my old server and also does not show on my present one.
    running centos 6.8 and InterWorx-CP v5.1.41 [Unlimited Domain]
    would be interested in the outcome of this issue and what was done to fix it.
    Gary T

  3. #18
    Join Date
    Apr 2012
    Posts
    2,127
    Points
    21,893
    Level
    64
    Hi
    I completely wiped and reloaded a test server today, Centos 7 with IW-CP 5.1.41 (no updates installed), and I was able to see the Iworx DB was missing from myphpadmin.
    This was good news and bad, bad, it was not shown but good news was I reproduced issue.
    Please could I ask if all of you had issues with myphpadmin from first install, i.e. myphpadmin errored on sessions
    This is exactly what my new install showed - myphpadmin error on sessions, I corrected and when accessing myphpadmin, no Iworx DB shown - only localhost
    If this is the case, and might be worth trying anyway, to resolve to show Iworx DB as follows:
    SSH into server
    (all as root)
    check and make sure /usr/local/interworx/lib/phpMyAdmin3/sessions folder exists, if it does not, create it
    check permissions on the following
    /usr/local/interworx/var/session
    drwx------. 2 iworx iworx 12288 Nov 12 21:06
    /usr/local/interworx/lib/phpMyAdmin3/sessions
    drwx--x--x 2 iworx-pma iworx-pma 4096 Nov 12 20:58
    if both folders are present, with correct permissions, then proceed to clear all session files from the 2 folders
    Sessions files to delete from the following folders
    /usr/local/interworx/lib/phpMyAdmin3/sessions
    /usr/local/interworx/var/session
    Restart iworx
    logout of SSH
    close your browser and clear browser cache
    login to nodeworx and confirm if Iworx DB now shown
    Hopefully this resolves your issue but sorry if it does not, it has on my test server where I was able to reproduce the issue
    Many thanks
    John

  4. The Following User Says Thank You to d2d4j For This Useful Post:


  5. #19
    Join Date
    Jul 2006
    Posts
    228
    Points
    9,274
    Level
    41
    Hi

    yes I had the same sessions phpmyadmin error when first installed, in my case there was a missing sessions folder in phpMyAdmin3. added the folder and checked folder permissions. this cured the phpmyadmin error.

    I have once again tried changing MySQL password and following your advice above but still no Iworx DB is shown, only localhost.
    would be interested if anyone contacted support what the out come was and how the issue was fixed.
    thank you for your time
    Gary T

  6. #20
    Join Date
    Apr 2012
    Posts
    2,127
    Points
    21,893
    Level
    64
    Hi bear

    Many thanks

    Did you delete all session files from the 2 folders, restart iworx and clear your browser cache

    When accessing phpmyadmin first time, do so from nodeworx, services, myphpadmin, which should set the new session and iworx db should be shown

    Many thanks

    John

  7. #21
    Join Date
    Apr 2012
    Posts
    2,127
    Points
    21,893
    Level
    64
    Sorry, a ticket needs to be open by a user with the issue, so I cannot open a ticket as I corrected mine and shows

    I'll email Iw with this thread though

    Many thanks

    John

  8. #22
    Join Date
    Jul 2006
    Posts
    228
    Points
    9,274
    Level
    41
    yes deleted all session files from the 2 folders, restarted iworx and cleared browser cache.
    will have another look later as away from my pc, thanks for your reply
    Gary T

  9. #23
    Join Date
    Jun 2014
    Posts
    217
    Points
    3,880
    Level
    26
    Has this ever been fully resolved? I have the same issue on 2 of 8 servers, all of them running the same IW version and either Centos 6.9 or 7.3.
    I tried your tipps from post #18 John, but to no avail.

    Since I am preparing to move all accounts from the relevant servers I really would like to be able to bulk edit the DNS TTL first....

    Cheers,

    Michael

  10. #24
    Join Date
    Apr 2012
    Posts
    2,127
    Points
    21,893
    Level
    64
    Hi Michael

    Many thanks

    Sorry, this issue is very intermittent and therefore extremely hard to diagnose/resolve when installing IW

    The above has always corrected this, but as I said, it needs someone with the issue to open a ticket so IW could have a look.

    Are you sure the permissions etc are correct, and all sessions cleared (this is where it could show not showing when it is)

    Please understand, I do not doubt you have completed the fix correctly, just double checking

    If you want to pm/email me login details to one server, I'll have a look late today, but as the issue is present, I would open a support ticket to let IW see what's happening

    I hope that helps a little

    Many thanks

    John

  11. The Following User Says Thank You to d2d4j For This Useful Post:


  12. #25
    Join Date
    Jun 2014
    Posts
    217
    Points
    3,880
    Level
    26
    Hi John,

    you have mail

    Cheers,
    Michael

  13. #26
    Join Date
    Apr 2012
    Posts
    2,127
    Points
    21,893
    Level
    64
    Hi Michael

    Many thanks

    After many hours checking and rechecking, thinking as I could see absolutely nothing wrong, IW-Jenna provided the answer. Kudos to IW

    You need to turn on debug mode in nodeworx, server settings, setting, debug (note do not turn on debug template), save and check in phpmyadmin

    You should now see iworx-db as well as local

    Take note

    Any changes to iworx-db you make at your own risk. Iw cannot be held for failure if you change anything in iworx-db. Even my posts could cause some IW to fail, due to each server been different.

    Many thanks

    John

  14. The Following User Says Thank You to d2d4j For This Useful Post:


  15. #27
    Join Date
    Jun 2014
    Posts
    217
    Points
    3,880
    Level
    26
    Hi John,

    oh, wow, that's an unexpected solution. You never stop learning....
    So I guess at one point IW support might have turned that setting to "on" on 2 of our other servers and I will have copied all settings to our newer servers, that's why they all work and the others don't.

    But thank you so much for looking yourself and for involving IW Jenna - she always delivers, doesn't she

    Thanks Jenna, if you are reading this!

    All the best

    Michael

  16. The Following User Says Thank You to mdeinhardt For This Useful Post:


  17. #28
    Join Date
    Dec 2016
    Posts
    9
    Points
    287
    Level
    5
    you have to click localhost and it is a drop down option

  18. #29
    Join Date
    Jun 2014
    Posts
    217
    Points
    3,880
    Level
    26
    Hey bestellen,

    you are right, but that option is only there, if you turned on debug mode in nodeworx, server settings, setting, debug - as John resp. Jenna through him described it above.

    Thanks

    Michael

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •