Results 1 to 2 of 2
  1. #1
    Join Date
    Jun 2014
    Posts
    222
    Points
    4,295
    Level
    27

    Softaculous sometimes has problems cloning sites + Solution

    Hi all,

    just wanted to let you know about an issue I have cleared with the Softcaulous support in case somebody else encounters this:

    Here's our ticket:
    We have several servers runnning Softaculous and encounter a problem with wordpress cloning since a while. The problem occurs during the checking phase, the cloning process says "Checking the submitted data" and then gets stuck at exactly 95%, on all servers I have tested. We are running Soctaculous on Centos 6.9 or 7.3 machines with the latest Interworx panel.
    and here's what they found:
    We were able to debug the issue.

    Softaculous executes on /home/interworx/bin/php binary of Interworx panel. But this binary does not have user access. When commands such as clone, auto backup, auto upgrade, etc are executed as user, Softaculous step down as user and executes these commands.

    Due to this, user does not have access to this binary in clone, hence we make use of the default php binary of the server.

    Now on your server, both the binaries have a different PHP version and both require different ionCube Loaders to decode the files. This is causing the issue as Softaculous files are encoded according to the version of /home/interworx/bin/php binary and in clone, executed with a different binary having a different version which requires different version of ionCube Loader.

    We'll make a fix for this in which we'll ask users about the PHP binary to be used. But this will take some time. Till then, please make both the PHP binaries on same PHP version and then check.
    So, either keep your php on 5.6.30 (which is the current php-iworx version) or wait for a softaculous update if you also have this issue.

    Cheers,
    Michael

  2. The Following User Says Thank You to mdeinhardt For This Useful Post:


  3. #2
    Join Date
    Apr 2012
    Posts
    2,179
    Points
    24,148
    Level
    67
    Hi Michael

    Excellent post, kudos to you

    Interestingly, the RC update which caused a few issues with smarty, I believe also updated ioncube loaders, so I'm thinking softaculous and IW may have resolved this.

    Sorry if I'm wrong though in advance

    Many thanks

    John

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •