Results 1 to 3 of 3
  1. #1
    Join Date
    Jun 2014
    Posts
    205
    Points
    3,538
    Level
    24

    phpinfo shows wrong PHP version

    Hi all,

    I have 3 accounts, where I phpinfo(); only shows PHP Version 5.6.31, no matter what I do. In siteworx it shows PHP Version: PHP-FPM 7.1.7, on the User shell entering php -v I get PHP 7.1.7 - so phpinfo is wrong.
    But all other accounts on the same server always show the correct versions, only these 3 fail. I checked the vhost files, htacess, redirects, permisssione etc. And I tried all php versions, back and forth :-(

    Does anyone have an idea?

  2. #2
    Join Date
    Apr 2012
    Posts
    2,072
    Points
    20,348
    Level
    62
    Hi Michael

    Sorry, I've been bogged down dealing with a client, who we carry out IT on insolvencies

    The only thing which comes to mind, is phpinfo running as the correct owner (but you said you'd checked perms)

    I'm thinking it's running differently or perhaps the user.ini is directing it to other php version.

    Just guessing here sorry, as php -v after ssh as siteworx user is showing corrrct php version

    Are any of your other servers showing same (have you tried duplicating siteworx account onto different server and does it show same)

    I hope that helps but it's so busy next few days


    Many thanks

    John

  3. The Following User Says Thank You to d2d4j For This Useful Post:


  4. #3
    Join Date
    Jun 2014
    Posts
    205
    Points
    3,538
    Level
    24
    Thanks John. I have not yet found the time to duplicate the account, I'll kepp you and all others updated, if and when I get to the bottom of this.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •