Page 1 of 2 12 LastLast
Results 1 to 15 of 17
  1. #1
    Join Date
    Jul 2006
    Posts
    246
    Points
    9,700
    Level
    42

    siteworx and webmail login warnings question?

    searched for the answer but could not find anything.

    When you visit siteworx and webmail you get a warning due to there being no ssl cert on there.

    Is there a way to use an excising ssl cert with the siteworx login so there is no warning notice?

    webmail login, is there a way to go to mydomain/webmail and use a ssl cert so there is no warning notice?
    failing that using the ip address/webmail login, can this be configured so there is no warning notice?

    Thank you.
    Gary T

  2. The Following User Says Thank You to bear For This Useful Post:


  3. #2
    Join Date
    Apr 2006
    Location
    Louisville, KY
    Posts
    192
    Points
    7,635
    Level
    37
    What kind of "existing cert" do you mean? If you already have a SSL certificate for your domain and it works for home, the same cert should cover the webmail URL. The same cert should also work for Siteworx if you prefer names instead of IPs. For control panels I prefer using https with the server IP and just add an exception in the browser to nix the error.

    If you don't have a cert for the domain then try the LetsEncrypt plugin. You don't need to add an extra namespace for the webmail URL.

  4. The Following User Says Thank You to sysnop For This Useful Post:


  5. #3
    Join Date
    Apr 2012
    Posts
    2,179
    Points
    24,145
    Level
    67
    HI Bear
    Sysnop is correct in all aspects.
    You could use your nodeworx ssl (as long as it is not self signed).
    Your IP would not have a SSL on it due to SSL no longer available for IP addresses
    You could use the Lets Encrypt plugin, and get an SSL from SSL on the domains you wish to use
    If using your nodeworx SSL, you are best advised to change the rewrite for /webmail to go to yourdomainnodeworx/webmail eg if a browser requested clientdomain/webmail, th erewrite goto yourdomainnodeworx/webmail
    Kudos to Sysnop
    Many thanks
    John

  6. The Following User Says Thank You to d2d4j For This Useful Post:


  7. #4
    Join Date
    Apr 2006
    Location
    Louisville, KY
    Posts
    192
    Points
    7,635
    Level
    37
    SSL gets easier and LetsEncrypt gets greater once it starts supporting wildcards, in early 2018 I think.

  8. #5
    Join Date
    Jul 2006
    Posts
    246
    Points
    9,700
    Level
    42
    Hi
    sorry did not explain that to well got a bit mixed up.

    I already have a SSL certificate for a domain and works ok on hrrps but when browsing to either https://domain.com:2443/webmail/ or https://domain.com:2443/siteworx/ I get

    There is a problem with this website’s security certificate

    do I have to edit a file to get it working with webmail and siteworx.

    Thank you
    Gary T

  9. #6
    Join Date
    Apr 2012
    Posts
    2,179
    Points
    24,145
    Level
    67
    Hi bear

    Many thanks

    I think you have the address wrong, unless Iím been too literal sorry

    The correct domain webmail access is

    https://siteworxdomain/webmail

    You have :2443 in your link, so it will give a warning

    I hope that helps

    Many thanks

    John

  10. #7
    Join Date
    Apr 2006
    Location
    Louisville, KY
    Posts
    192
    Points
    7,635
    Level
    37
    I see what bear means about Siteworx. It seems we're talking two different issues with different answers.

    Since I use IPs and it never occurs to me to use domains for Siteworx, I hadn't noticed that using a Siteworx URL without port 2443 still redirects using the port #, and that's why the browser can't accept the certificate using https domain/siteworx -- because the port # gets inserted either way.

    You're right about editing a file and like John suggested earlier, I believe you can setup a rewrite in your virtualhost file or with an .htaccess file in the domain's root directory. Sorry, I'm not smart enough about Apache to advise you well on this.

    Webmail is different and doesn't redirect, so you shouldn't be seeing this same behavior with the webmail URL. If you're still getting a browser error using https with domain/webmail minus the port #, then something is wrong.

  11. The Following User Says Thank You to sysnop For This Useful Post:


  12. #8
    Join Date
    Apr 2012
    Posts
    2,179
    Points
    24,145
    Level
    67
    Hi sysnop

    Iím glad you got it but sorry, I am slow sometimes and I am getting slightly lost sorry

    The :2443 is only used for IW-CP login

    The redirects are already present in iWorx.ini I think itís called

    These redirects are only for anything ending /nodeworx or /siteworx

    Ideally, the redirect server name needs changing to your domain used for logging in to IW-CP, which is usually the FQDN of the server

    This then redirects you https://serverdomain:2443/siteworx or /nodeworx as apposed to https://siteworxdomain:2443/siteworx or /nodeworx

    The latter would fail on ssl due to wrong ssl cert used by IW-CP

    I hope that makes sense sorry and if I have time next week, Iíll post exactly how to do this

    Merry Christmas and happy new year

    John

  13. #9
    Join Date
    Jul 2006
    Posts
    246
    Points
    9,700
    Level
    42
    when I go to https://domain.com/webmail/ it throws a 500 internal server error? that's why I thought it was incorrect url
    using it with the 2443 port works ok

    thanks again

    Happy Christmas and new year to you both
    Gary T

  14. #10
    Join Date
    Apr 2012
    Posts
    2,179
    Points
    24,145
    Level
    67
    Hi bear

    I think sysnop has a better understanding of the issue - Iím slightly busy sorry here - last working day for our clients

    What IW version are you using

    Are there anything shown in logs to help with error 500

    Have you made any changes to apache or iworx files for redirects

    I hope you donít mind me asking but it would help

    Many thanks

    John

  15. #11
    Join Date
    Apr 2006
    Location
    Louisville, KY
    Posts
    192
    Points
    7,635
    Level
    37
    Sorry again bear, I'm stumped by your 500 error. Something isn't right about your virtualhost or .htaccess if one exists. If you have an .htaccess try removing it temporarily just to see if the error goes away.

    Didn't you say in a different post that you're using intoDNS? I'm beginning to wonder if you need to bypass them while troubleshooting. You seem to have separate problems that may or may not be related to your SSL and PTR issues.

  16. The Following User Says Thank You to sysnop For This Useful Post:


  17. #12
    Join Date
    Apr 2006
    Location
    Louisville, KY
    Posts
    192
    Points
    7,635
    Level
    37
    I'm stepping away for the remainder of the weekend. Merry Christmas to John and the Interworx team!

    You too bear! and good luck with your server issues. The pieces will fall into place.

  18. The Following User Says Thank You to sysnop For This Useful Post:


  19. #13
    Join Date
    Apr 2012
    Posts
    2,179
    Points
    24,145
    Level
    67
    Hi sysnop

    I hope you and your loved ones have a lovely Christmas and happy new year

    Hopefully I will not be too long before I finish for a day or two

    Kudos to you for htaccess, as I think that maybe the issue perhaps

    Many thanks

    John

  20. #14
    Join Date
    Apr 2012
    Posts
    2,179
    Points
    24,145
    Level
    67
    Hi bear

    I was thinking about this and it is not a rewrite rule, or it should have taken you to port 2443 when detecting /webmail

    htaccess is a place to disable as sysnop states - kudos to sysnop. This could give a 500 error

    The other thing I thought of was the proxy settings, which webmail uses

    I suspect years ago you implemented a form of proxy or htaccess directive to take /webmail to port 2443

    If that is the case, I would suggest you open a support ticket with IW to have a look as it is guess work on our part

    If you do, please could you update your post to help others

    If you prefer not to open a support ticket, we will continue to help but would need more information from some files

    I hope that helps a little and have a lovely Christmas and a happy new year

    Many thanks

    John

  21. #15
    Join Date
    Jul 2006
    Posts
    246
    Points
    9,700
    Level
    42
    Good day to you.
    Thanks for all your help, this is a newly installed server/interworx but having a few issues so will open a ticket for support guys to have a look.
    I feel there are a few permissions wrong some where, no rush this side of xmas though.

    Happy xmas
    Gary T

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •