Results 1 to 8 of 8
  1. #1
    Join Date
    Jan 2004
    Location
    Pittsburgh, PA
    Posts
    1,209
    Points
    16,992
    Level
    56

    Exclamation Mail delivery problems related to ClamAV virus update (Jan 26 2018)

    It seems the world awoke today to the surprise of a clamav virus definition file causing clamd to hit open file limits, effectively breaking the virus scanner, and breaking mail delivery for a lot of folks.
    To address the issue on interworx servers, we've released a patched version of clamav that works around the problem, since an updated virus definitions file from clamav has not yet materialized.

    The updated clamav packages have been released to the iworx-stable rpm release channel. To apply the update manually, run:

    Code:
    $ yum update clamav
    Otherwise the update will be applied by interworx automatically as part of the daily maintenance cron.

    For reference the discussion of the issue is ongoing on the clamav mailing list:

    http://lists.clamav.net/pipermail/cl...ry/005655.html

    Paul
    Paul Oehler
    InterWorx-CP | http://interworx.com
    InterWorx Control Panel

  2. The Following 3 Users Say Thank You to IWorx-Paul For This Useful Post:


  3. #2
    Join Date
    Jan 2018
    Posts
    1
    Points
    3
    Level
    1
    Pual Nice work with us
    a Gaming Lover
    gaming

  4. #3
    Join Date
    Apr 2012
    Posts
    2,187
    Points
    24,579
    Level
    68
    Hi

    Good to see ClamAV updated to 99.3, including CVE patches

    Kudos interworx

    Many thanks

    John

  5. #4
    Join Date
    Apr 2006
    Location
    Louisville, KY
    Posts
    194
    Points
    7,708
    Level
    37
    Is this ClamAV issue related to my new problem which began yesterday? Outside host names aren't being resolved which means the license server can't be reached meaning more trouble ahead.

    The error when sending mail from a remote client (Thunderbird):

    DNS temporary failure (#4.3.0).

    Mail appears to send from Squirrelmail or Roundcube but messages are stuck in queue.

    Yum update failing too.

    I'm on ClamAV 99.3.

    Help appreciated.
    Last edited by sysnop; 01-30-2018 at 10:10 AM.

  6. #5
    Join Date
    Apr 2012
    Posts
    2,187
    Points
    24,579
    Level
    68
    Hi Sysnop
    I hope your well
    I would check resolv.conf to make sure you have external dns listed (vi /etc/resolv.conf), if not add and save the following
    nameserver 8.8.8.8
    nameserver 8.8.4.4
    you may need to restart network/server but I do not think so
    whilst in ssh, can you test ping say google.com and does it work as expected
    Your issue I do not believe is as a result of clamAV update to 99.3
    Why yum update may fail I am not sure, perhpas need more info
    Is your time on server correct, if not this needs correcting and what happens if you manually try to register with IW licence
    service ntpd stop
    ntpdate ntp.interworx.com
    service ntpd start
    /home/interworx/cron/license.pex
    I hope that helps a little
    Many thanks
    John

  7. #6
    Join Date
    Apr 2006
    Location
    Louisville, KY
    Posts
    194
    Points
    7,708
    Level
    37
    Hi John,

    The ClamAV issue must be bad timing just for an extra variable to throw me off. My problem wasn't just mail transport, it's DNS failure in general and it's beginning to look like network problems on the ISP's end.

    Thanks!

  8. The Following User Says Thank You to sysnop For This Useful Post:


  9. #7
    Join Date
    Apr 2012
    Posts
    2,187
    Points
    24,579
    Level
    68
    Hi sysnop

    Sounds like my type of luck

    Good luck

    Many thanks

    John

  10. #8
    Join Date
    Feb 2018
    Posts
    1
    Points
    2
    Level
    1
    Best of luck

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •