Announcement

Collapse
No announcement yet.

Php5 / Mysql 4.1.9 Howto

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #76
    Thanks, Paul.

    I'll give it a shot this evening...

    --Noah

    Comment


    • #77
      I notice that there are 2 SRPMs for PHP5: 5.0.4 & 5.1.2.

      Will Iworx Chris's "rpmbuild --rebuild --with rhe4x http://updates.interworx.info/iworx/SRPMS/experimental/php-5.0.4-100.iworx.src.rpm"

      work for 5.1.2, or should I just use 5.0.4?

      Thanks,

      --Noah

      Comment


      • #78
        Hi guys!

        I want to upgrade php to the 5th version on CentOS 3.7 (final).

        I can ask my admin to do it, but need to be sure that he will not break
        the Iworx box accidentally.

        Can you point me to some tutorial? I read few forum posts, but
        found nothing about CentOS 3.7

        Comment


        • #79
          Originally posted by customs
          Hi guys!

          I want to upgrade php to the 5th version on CentOS 3.7 (final).

          I can ask my admin to do it, but need to be sure that he will not break
          the Iworx box accidentally.

          Can you point me to some tutorial? I read few forum posts, but
          found nothing about CentOS 3.7
          InterWorx has it's own PHP installed to run the panel itself. Upgrade the one on the box to your heart's content.

          Comment


          • #80
            I am trying to upgrade the PHP, as per Chris post I have installed most of the devel packages but this is the one that is causing conflict:

            [root@interworx i386]# rpmbuild --rebuild --with rhe4x http://updates.interworx.info/iworx/....iworx.src.rpm
            Installing http://updates.interworx.info/iworx/....iworx.src.rpm
            error: Failed build dependencies:
            libc-client-devel is needed by php-5.2.0-100.rhe4x.iworx.i386
            When I try to install it using Yum,

            [root@interworx i386]# yum install libc-client-devel
            Setting up Install Process
            Setting up repositories
            Reading repository metadata in from local files
            Excluding Packages in global exclude list
            Finished
            Parsing package install arguments
            Resolving Dependencies
            --> Populating transaction set with selected packages. Please wait.
            ---> Package libc-client-devel.i386 0:2002e-14 set to be updated
            --> Running transaction check
            --> Processing Conflict: libc-client-devel conflicts imap-devel
            --> Finished Dependency Resolution
            Error: libc-client-devel conflicts with imap-devel
            Any suggestions are much appreciated.

            Comment


            • #81
              No worries.I have taken care of it.

              Comment


              • #82
                Glad you got it sorted out. In case others have the same problem, what was the fix?
                Socheat Sou
                InterWorx-CP | http://interworx.com
                InterWorx Control Panel

                Comment


                • #83
                  Originally posted by IWorx-Socheat View Post
                  Glad you got it sorted out. In case others have the same problem, what was the fix?
                  It was a Virtuozzo VPS on which I was upgrading the PHP.Virtuozzo had installed the IMAP and that was conflicting. As I am using InterWorx on that VPS so the IMAP server installed by the Virtuozzo was useless. So the solution is to simply remove the installed Virtuozzo IMAP server.

                  Comment

                  Working...
                  X