Announcement

Collapse
No announcement yet.

InterWorx 1.9.0 Release

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Guest's Avatar
    Guest replied
    Originally posted by Justec
    InterWorx 1.9.1?

    What is included in this minor version upgrade?

    By the way with my stats turned off my webserver stayed up for the second straight day.

    Thanks,
    assuming it's like 1.8.1 it's just a bug fix since as you can see there was a lot of functionality added to 1.9.0. I see Paul has a post about it in the Anouncements forum.

    Leave a comment:


  • Justec
    replied
    InterWorx 1.9.1?

    What is included in this minor version upgrade?

    By the way with my stats turned off my webserver stayed up for the second straight day.

    Thanks,

    Leave a comment:


  • Guest's Avatar
    Guest replied
    Thanks Paul,

    Neither of these two issues are related to 1.9, but they are very good ideas. I'll move them to the Feature Requests section.
    Sorry I should write all these feature requests in the good forum

    The 5th parameter to the account_info variable, if provided, will be the language for the created account.
    Examples:
    'en-us'
    'fr'
    Default is en-us.
    Are you sure it is the 5th parameter ? Here are the parameters I have in the account_info variable.

    $ai_pseudo,
    $ai_email,
    $ai_passwd,
    $ai_domaine,
    $ai_ip
    Is the language option will be after or before the $ai_ip ?

    Thanks

    Pascal

    Leave a comment:


  • IWorx-Paul
    replied
    Originally posted by pascal
    Hello ;)

    Just a question relating to the 1.9 release :

    - Did you upgrade the "create siteworx account" parameters' API to have the language option, spam option, ... ?
    The 5th parameter to the account_info variable, if provided, will be the language for the created account.
    Examples:
    'en-us'
    'fr'
    Default is en-us.

    There's no spam-related stuff in the API yet.

    Originally posted by pascal
    About the bandwidth limit and the burstable option (not sure it is related to the 1.9) :

    - when a user exceeds the limit of bandwidth there is no mail alarm sent to the administrator of the box. It's a shame, as I can't check all account every days and I can't force the burstable option to OFF (in fact I could by tweaking the theme)

    - I have a user who had exceeds his bandwidth limit. His account had been created on february 12th. I told him, I'd wait until his birthday date, to send him an invoice for the exceedent bandwidth used. But on the March 1st, his bandwidth data has been reseted. So I can't know how much he exceeded his bandwidth during his one month subscription (ended on march 11th), also I couldnt invoice this bandwidth's going beyond to him.

    Maybe it is not related to the 1.9 release, but it could be great to have :
    - an email alert to the box admin when a siteworx account reach his bandwidth limit
    - the ability to allow or disallow the burstable option (if the box admin disallow it, the siteworx user couldn't allow it)
    - Be sure to be able to follow up the exceed bandwidth during every birthday period (I mean, If a siteworx account is created on xxxx 10th, the bandwidth used should not be reseted before the 9th of the next months) and receive an email alert when the bandwidth used is reseted (only in case of the limit has been reach).

    Regards
    Pascal
    Neither of these two issues are related to 1.9, but they are very good ideas. I'll move them to the Feature Requests section.

    Paul

    Leave a comment:


  • Justec
    replied
    I've shut off my AW and Analog stats. The webserver didn't shut down today (but then again it has'nt happen everyday even with the stats running).

    I will leave them off for about a week and see if that resolves the problem. It seems I'm the only one that has had this problem of Apache shutting down and not restarting during the stats program running.

    Leave a comment:


  • Guest's Avatar
    Guest replied
    Hello ;)

    Just a question relating to the 1.9 release :

    - Did you upgrade the "create siteworx account" parameters' API to have the language option, spam option, ... ?


    About the bandwidth limit and the burstable option (not sure it is related to the 1.9) :

    - when a user exceeds the limit of bandwidth there is no mail alarm sent to the administrator of the box. It's a shame, as I can't check all account every days and I can't force the burstable option to OFF (in fact I could by tweaking the theme)

    - I have a user who had exceeds his bandwidth limit. His account had been created on february 12th. I told him, I'd wait until his birthday date, to send him an invoice for the exceedent bandwidth used. But on the March 1st, his bandwidth data has been reseted. So I can't know how much he exceeded his bandwidth during his one month subscription (ended on march 11th), also I couldnt invoice this bandwidth's going beyond to him.

    Maybe it is not related to the 1.9 release, but it could be great to have :
    - an email alert to the box admin when a siteworx account reach his bandwidth limit
    - the ability to allow or disallow the burstable option (if the box admin disallow it, the siteworx user couldn't allow it)
    - Be sure to be able to follow up the exceed bandwidth during every birthday period (I mean, If a siteworx account is created on xxxx 10th, the bandwidth used should not be reseted before the 9th of the next months) and receive an email alert when the bandwidth used is reseted (only in case of the limit has been reach).

    Regards
    Pascal

    Leave a comment:


  • kipper3d
    replied
    Good morning,

    Appears 1.9 was released 02-27-2005. One of my servers that set to auto update, never updated. I even refreshed and ran install in the updates section in nodeworx, but still nothing. I havent tried yum update yet. Wondering if there was a reason it wasn't updated.

    Other problem, is my AMD64 server, interworx appears to be broken. Perhaps needs to be recompiled for the update?

    Thanks,

    Leave a comment:


  • IWorx-Socheat
    replied
    Originally posted by RWF
    I guess I have to open a support ticket about this. I just can't believe that this file is not plain text that could be understood by Notepad.
    Though the issue was fixing the permissions, just wanted to make another comment. While the file is plain text, and is understood by Notepad, Unix and Windows use different characters to represent a newline. This is what caused the "funky" characters and everything to appear on a single line in Notepad.

    Leave a comment:


  • Guest's Avatar
    Guest replied
    Originally posted by IWorx-Paul
    RWF, the permissions are almost certainly the issue. Log into the server as root and run the following command:

    chown iworx.iworx /home/interworx/iworx.ini
    chmod 600 /home/interworx/iworx.ini

    Paul

    Thanks! Actually the first line was enough to get thing to work again :)

    Leave a comment:


  • Justec
    replied
    From the shell you just type "vi filename" and it will open the editor.
    It is not with your SSH program it is in Linux and almost every Linux distro has
    VI.

    Another good practice is to make a backup of any config file before you edit it so if you mess up you can copy it back over from the backup file.

    cp interworx.ini interworx.ini.bak_3-2-05

    then if you mess up you just cp interworx.ini.back_3-2-05 interworx.ini

    Leave a comment:


  • IWorx-Paul
    replied
    RWF, the permissions are almost certainly the issue. Log into the server as root and run the following command:

    chown iworx.iworx /home/interworx/iworx.ini
    chmod 600 /home/interworx/iworx.ini

    Paul

    Leave a comment:


  • Guest's Avatar
    Guest replied
    This is first text line of the error text I get now when trying to go to Interworx.

    Warning: parse_ini_file(): Cannot open '/home/interworx/iworx.ini' for reading in /home/interworx/include/INIConfig.php on line 44


    I guess I have to open a support ticket about this. I just can't believe that this file is not plain text that could be understood by Notepad.

    Leave a comment:


  • Guest's Avatar
    Guest replied
    Originally posted by Justec
    You should just edit the files with SSH using the VI editor. If you download them to windows you can use it with notepad i think (not word or wordpad).

    As to the stats themselves, mine run at 8.30 ish in the morning at the same time as my update and i have about 99% CPU load for 5 mins or so.

    I would really like to know how we can adjust the times of the update and stats run at.

    Thanks for your advise, however my SSH program (SSH Secure Shell v.3.1.0) does not have anything called VI-Editor, never seen it, and I did a search in the help section.


    And I did open the ini file in Notepad, but like I said everything was on one line with funky characters between was should be lines.

    Leave a comment:


  • Guest's Avatar
    Guest replied
    Originally posted by IWorx-Chris
    I wouldn't copy it back / forth RWF even while pasting just to keep errors to a minimum. Just edit it in place with emacs, vi, pico etc.

    Chris

    This is how I 've done it succesful before with fx. webalizer.conf. Anways too late for advising not to copy and paste, and I tried just downloading and editing the file first.

    Now the file is apparently messed up, and I do not have any of the apps you talk about. How do I fix the file? It seems to be in plain text format, but is apparently not understood by Interworx.

    Leave a comment:


  • Justec
    replied
    Originally posted by RWF
    Ok I opened the file via SSH and edited with Notepad. However there where all these "funky" characters in Notepad instead line breaks. This I ignored found the text, edited, saved, and uploaded. Then Interworx would not work.

    Then I opened the file again, in Notepad, copied and pasted into Word, and back into Notepad, so the funky line breaks where treated in Notepad as regular line breaks, everything was not on the same line, uploaded, and Interworx still does not work?

    Should that ini file not be a regular text file?
    You should just edit the files with SSH using the VI editor. If you download them to windows you can use it with notepad i think (not word or wordpad).

    As to the stats themselves, mine run at 8.30 ish in the morning at the same time as my update and i have about 99% CPU load for 5 mins or so.

    I would really like to know how we can adjust the times of the update and stats run at.

    Leave a comment:

Working...
X