Announcement

Collapse
No announcement yet.

MySQL Server version: Unknown

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • MySQL Server version: Unknown

    Hello,

    I reinstalled one of our VPS (Centos 6.6 x64, IW 5.0.15-700) and I discovered that the MySQL server not working good. In NodeWorx the version of MySQL is unknown and the MySQL Server Options are empty. In SiteWorx, when I try to create a database I can see only the following message: MySQL server not running.

    It's a clean install without modifications made 2-3 ours ago.

    Do somebody have any idea what could be wrong?

  • #2
    Hi dss

    That's the second user to state MySQL not working upon a fresh install of IW on vps

    What is your vps

    Also, I'd open a ticket to let IW have a look to see what's going on

    I hope that helps

    Many thanks

    John

    Comment


    • #3
      Hi John,

      Thank you for your reply! It's a small OpenVZ VPS with 1GB of RAM. As I remember the older versions were good on the same VPS.

      Comment


      • #4
        Hi dss

        Many thanks, and sorry, I'm sure you have but what comes to mind quickly with openvz, did you enable second level quotas

        If not, I suspect this is the issue

        Hope that helps

        Many thanks

        John

        Comment


        • #5
          Hi John,

          My previous post was wrong, it's not OpenVZ it's KVM.

          Comment


          • #6
            Hi dss

            Many thanks

            Have you tried to manually start MySQL from ssh.

            If so, did you note any errors or are there any errors shown in install log for IW

            I'm wondering if perhaps a download link has been set to wrong address/reference, as this seems to have appeared directly after centos 7 pre beta were released.

            I could be entirely wrong though, so apologies in advance.

            I will try to do a fresh test install myself tonight or tommorow on centos 6, and see if I have same issues, but I would open a support ticket as it is most unusual

            I'm sorry I can't be any more helpful at this moment

            Many thanks

            John

            Comment


            • #7
              Hi John,

              Yes, I tried. I didn't find any error in the log files. As I remember the working install was before the CentOS 7 release.

              I checked the remote servers in MySQL settings (I don't know why because I don't have :D) and find this:

              Click image for larger version

Name:	remote_sql.jpg
Views:	1
Size:	45.3 KB
ID:	40537

              After clicking on Reactivate Server it asks for the database root username / password.

              Comment


              • #8
                Hi dss

                Many thanks, I think that helps a lot.

                I'm thinking more then before, it is pulling from a pre beta centos 7 area when first running IW install, and therefore may look for remote server, with centos 7 been partitioned (sorry for wrong wording, just cannot remember the correct term used for centos 7)

                I'll let you know how my install goes, but it will be on a physical server not vps, but at least it will answer my theory of above

                Many thanks

                John

                Comment


                • #9
                  Hi John,

                  Thank you, I'm waiting for your experiences!

                  I checked the MySQL version of the affected server and a working (physical) server, you can see below:

                  Code:
                  [root@srv2 ~]# yum list installed | grep mysql
                  mysql.x86_64                        5.1.73-3.el6_5            @base
                  mysql-devel.x86_64                  5.1.73-3.el6_5            @base
                  mysql-iworx.x86_64                  4.0.21-12.rhe6x.iworx     @interworx-release
                  mysql-libs.x86_64                   5.1.73-3.el6_5            @updates
                  mysql-server.x86_64                 5.1.73-3.el6_5            @base
                  php-mysql.x86_64                    5.3.3-40.el6_6            @updates

                  Comment


                  • #10
                    It's a known issue, you'll need to contact InterWorx as it is very complex to fix, what the issue is that you installed it when the mysql repo wasn't available, so it installs it after and that causes the wrong hash. They can fix it for you in about 16 minutes.
                    Michael Dance
                    Licensecart Certified Distribution for Blesta, Interworx, KernelCare, CraftSRV, Softaculous, SolusVM, LiteSpeed & SSLs.
                    Free Softaculous & 50% off KernelCare with every InterWorx license bought with us. We pride ourselves by being the cheapest External provider.
                    Need Help? Check out the InterWorx FAQs or check out our Knowledgebase. In the InterWorx family, you're never alone!

                    Comment


                    • #11
                      Hi Dss
                      Many thanks Mike (Licencecart), I did not know that, but good to know for future.
                      I was going to post anyway and state my theory was completely wrong, as a test install went lovely first time, all working as expected.
                      Dss, below is the output, so it looks like we match.
                      I'm sorry I was not able to help but glad it is an easy fix
                      Many thanks
                      John
                      Last login: Wed Jan 7 21:39:56 2015 from nnn.nnn.nnn.nnn
                      [root@localhost ~]# service mysqld status
                      mysqld (pid 1812) is running...
                      [root@localhost ~]# pgrep -u mysql mysqld
                      1812
                      [root@localhost ~]# yum list installed | grep mysql
                      mysql.x86_64 5.1.73-3.el6_5 @base
                      mysql-devel.x86_64 5.1.73-3.el6_5 @base
                      mysql-iworx.x86_64 4.0.21-12.rhe6x.iworx @interworx-release
                      mysql-libs.x86_64 5.1.73-3.el6_5 @base
                      mysql-server.x86_64 5.1.73-3.el6_5 @base
                      php-mysql.x86_64 5.3.3-40.el6_6 @updates
                      [root@localhost ~]#

                      Comment


                      • #12
                        Hi dss and mike

                        I'm sorry, my fresh install last night on a test server, using centos 6.6 64 bit, full server and IW cp 5.-15 is showing the same error as dss reported here., exactly.

                        My mistake was to see IW-cp up and running, and ssh showed MySQL running, as did the default home page of nodeworx after first logging in.

                        I appreciate what mike has posted, but with 3 different users installing fresh IW on 3 different platforms on different days, I would be inclined to think that something has changed, unless it is a long term issue for downloading MySQL.

                        Either way, I would consider this not good and could be detrimental to IW if it's not resolved fully.

                        I'll open a support ticket after I have changed the test server to an external ip, incase they want to look.

                        Once again, sorry dss, I should have fully checked, but guess tiredness got the better of me sorry

                        Many thanks

                        John

                        Comment


                        • #13
                          Hi John and Michael,

                          Thank you for your replies and the tests!

                          Yes, everything looks good in NodeWorx until you don't check the MySQL server settings. In my case it's not too important to fix it because it's a "DNS-only" and backup server so I can wait for the fix. I've just reported the problem because I didn't know if it was an individual problem or not.

                          Comment


                          • #14
                            Hi

                            I was thinking about Mike post re hash causing issue due to repo not available, so I thought I would check when installed, which belows shows to me anyway, both MySQL repo available and installed in a timely fashion, with ver 5 first, then ver 4, so I am thinking it a little more then hash.
                            I could be wrong though, so apologies in advance.
                            Many thanks
                            John
                            Jan 07 20:12:16 Installed: mysql-libs-5.1.73-3.el6_5.x86_64
                            Jan 07 20:12:16 Installed: mysql-5.1.73-3.el6_5.x86_64

                            Jan 07 20:12:19 Installed: mysql-devel-5.1.73-3.el6_5.x86_64
                            Jan 07 20:13:01 Installed: mysql-iworx-4.0.21-12.rhe6x.iworx.x86_64

                            150107 20:12:21 [Note] /usr/libexec/mysqld: ready for connections.
                            Version: '5.1.73' socket: '/var/lib/mysql/mysql.sock' port: **** Source distribution
                            150107 20:18:20 mysqld started
                            /home/interworx/bin/iworx-db: ready for connections.
                            Version: '4.0.21' socket: '/home/interworx/var/run/mysql.sock' port: **** Source distribution
                            Note **** replaces correct port number

                            Comment


                            • #15
                              Hi

                              Sorry, it is a hash issue, IW have just confirmed this.

                              IW hopefully should be fully resolving before long, so normal installs can take place without issues.

                              Thanks to dss for raising this, and everettmarshall, who suffered the same issue, but in the meantime, of anyone experiences this issue, I would advise open a support ticket with IW, who will be able to correct it.

                              Many thanks

                              John

                              Comment

                              Working...
                              X