Announcement

Collapse
No announcement yet.

CNAMEs with underscores

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • CNAMEs with underscores

    Hi all,

    I'm not sure whether this is a bug or it has been restricted to this for whatever reason. We have a client who wishes to add 2 CNAMEs to his domains DNS records.

    zendesk1._domainkey.domain.com must point to zendesk1._domainkey.zendesk.com
    zendesk2._domainkey.domain.com must point to zendesk2._domainkey.zendesk.com

    The first part of the record is fine and it is accepted but the second part which is:

    zendesk1._domainkey.zendesk.com

    Is not accepted and comes up with an ! mark. It seems it will only accept it when the _ has been removed.

    They are valid records as they do seem to be accepted by Cloudflare. Is there a way round this for the Interworx control panel to accept the above CNAME records?

    Kind Regards,

  • #2
    Hi Bertie

    Welcome to IW forms
    We use same distro and latest IW, but cannot replicate your issue. (please see pics)
    I would suggest you fully restart your server and test again.
    If your issue is still present, as you cannot add the cname, there will be no log entries to show any failures, but a screenshot does help, so I would suggest you open a support ticket with IW or your license provider, and let them have a look.
    I hope that helps
    Many thanks
    John
    Attached Files

    Comment


    • #3
      Hi Bertie

      I'm sorry, I was thinking of bblori post and you have not stated your distro or Iw version

      What distro and Iw version are you using

      The above was centos 6.8 and latest Iw version

      I'll try centos 7 when I'm back

      Many thanks

      John

      Comment


      • #4
        Hi Bertie
        I have tried centos7 and latest IW version, which worked lovely
        I would open a supportticket with your license provider and let them have a look, unless you may have mistyped when setting up Cname (sorry, all I could think off as to why it might fail)
        Many thanks
        John
        Attached Files

        Comment


        • #5
          Thanks for replying. It looks like we were running a few versions behind on Interworx and the bug has been fixed in one of the recent versions.

          All sorted now! :)

          Comment

          Working...
          X