Announcement

Collapse
No announcement yet.

/siteworx/ was not found on this server

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • /siteworx/ was not found on this server

    Is there a way to get the /siteworx/ and /nodeworx/ to work again? Like if we did the following:

    https://cp2.domain.com/siteworx/?domain=test.com it will give us a:

    Not Found

    The requested URL /siteworx/ was not found on this server.
    Same would happen to Nodeworx as well - It works fine on one of our other interworx installations but not this one. We have to physically put in the port numbers such as:

    https://cp2.domain.com:2443/siteworx/?domain=testing.com for it to load the login page.

  • #2
    Hi Bertie

    The rewrite is found in the iworx.conf file (~iworx/iworx.conf)

    SSH into your server, edit iworx.conf, Locate the standard http rewrite, copy and paste and change the http to https, save and restart iworx - service iworx restart

    Please be careful not change anything other then above in iworx.conf, as changes could stop iworx working

    I hope that helps a little

    Many thanks

    John

    Comment


    • #3
      Hi Bertie
      Sorry, my first post I do not think would work, and your are most likely wanting to cover all IP access, as well as any failed error 404 on IP address (if SSL is not setup on a siteworx domain, it reverts to apache www), so the following should help you acheive your goal. However, it is untested so cannot guarantee it will work as expected fully
      Fist, SSH into server, and edit /etc/httpd/conf/httpd.conf
      locate and delete the hash for HTTP_NOT_FOUND.html.var
      *** eg ***
      Alias /error/ "/var/www/error/"
      <IfModule mod_negotiation.c>
      <IfModule mod_include.c>
      <Directory "/var/www/error">
      AllowOverride None
      Options IncludesNoExec
      AddOutputFilter Includes html
      AddHandler type-map var
      Order allow,deny
      Allow from all
      LanguagePriority en es de fr
      ForceLanguagePriority Prefer Fallback
      </Directory>
      # ErrorDocument 400 /error/HTTP_BAD_REQUEST.html.var
      # ErrorDocument 401 /error/HTTP_UNAUTHORIZED.html.var
      # ErrorDocument 403 /error/HTTP_FORBIDDEN.html.var
      ErrorDocument 404 /error/HTTP_NOT_FOUND.html.var
      # ErrorDocument 405 /error/HTTP_METHOD_NOT_ALLOWED.html.var
      # ErrorDocument 408 /error/HTTP_REQUEST_TIME_OUT.html.var
      # ErrorDocument 410 /error/HTTP_GONE.html.var
      # ErrorDocument 411 /error/HTTP_LENGTH_REQUIRED.html.var
      # ErrorDocument 412 /error/HTTP_PRECOND
      save
      then edit /var/www/error/include/top.html
      add the following line in the head section, please change yourserverhostname.url to match your server host name or the domain url used for siteworx login (please note I have left it non secure, as the rewrite rules of Iworx will convert to secure for you)
      <meta http-equiv="Refresh" content="1; url=http://yourserverhostname.url/siteworx">
      *** eg ***
      <head>
      <title><!--#echo encoding="none" var="TITLE" --></title>
      <link rev="made" href="mailto:<!--#echo encoding="url" var="SERVER_ADMIN" -->" />
      <style type="text/css"><!--/*--><![CDATA[/*><!--*/
      body { color: #000000; background-color: #FFFFFF; }
      a:link { color: #0000CC; }
      p, address {margin-left: 3em;}
      span {font-size: smaller;}
      /*]]>*/--></style>
      <meta http-equiv="Refresh" content="0; url=http://yourserverhostname.url/siteworx">
      </head>
      (please note - The content="0; is the timer for refresh, so setting it to 1, would give a 1 second delay etc, so change to suit your needs )
      save
      restart apache - service httpd restart
      test by access using IP address or that of a domain with no SSL setup
      you can edit the 404 error page by editing /var/www/error/HTTP_NOT_FOUND.html.var
      As I said though, the above may not work as expected, so I apologise in advance, but would be interested to know how other users have done this
      Many thanks
      John

      Comment


      • #4
        Thanks, will let you know how I get on.

        Comment

        Working...
        X