Announcement

Collapse
No announcement yet.

Disabled Spam + Virus Services keep Restarting

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Disabled Spam + Virus Services keep Restarting

    Hi,

    I have already reported this bug several month ago here on this forum (http://forums.interworx.com/threads/...tart-on-Reboot) and I have also contact directly InterWorx Support Team using their Ticket system during 2016 year and they confirm the bug from they end... but until now the bugs are not fixed.

    The problem is that even after I Turn Off and Disable from Start on Boot the Spam + Virus Filtering services, they will start after a server reboot.

    Of course this causes a lot of problem with high resource usage and forces me to login Interworx and manually disable this services after every reboot or downtime on all servers where I use Interworx but not any kind of email services.

    Note: I have experience this bug using Interworx latest version on multiple installations on servers running on CentOS 7.3 (tested on both OpenVZ and also KVM virtual servers)

    So can anyone else confirm this bugs? Also can Interworx support team resolve this bugs on a near future Interworx update?

    Thanks

  • #2
    Hi nqservices

    Many thanks

    Please could I ask exactly how to replicate and I will test after 10 days (family commitments sorry)

    I would think though, if I understand your post, could you not just uninstall spam assassin and clamav

    Many thanks

    John

    Comment


    • #3
      Originally posted by d2d4j View Post
      Please could I ask exactly how to replicate and I will test after 10 days (family commitments sorry)

      I would think though, if I understand your post, could you not just uninstall spam assassin and clamav
      To replicate from your end, follow the steps:

      1- Install Interworx latest version on a OpenVZ or KVM VPS running the latest CentOS 7 OS.
      2- After installation is done > Login NodeWorx
      3- Go to menu System Services > Spam Filtering > and there check "NO" on the option: "Start on boot-up" on "SpamAssassin Control"
      4- Go to menu System Services > Virus Filtering > and there check "NO" on the option: "Start on boot-up" on both "ClamAV Control" + "FreshClam Control"
      5- Reboot server and login again on NodeWorx. You will see that both the Spam + Virus Filtering services are running.

      Now in terms of uninstall spamassassin and clamav, it can be an option.. Can you tell me how can I do it? Anyway, I think it would much more easy if InterWorx team can fix this bugs... that I have already reported many months ago.

      Thanks

      Comment


      • #4
        Hi all,

        Can someone please check to confirm if this bug also happens on your servers?

        @d2d4j Did you have the chance to test?

        Comment


        • #5
          Hi nqservices

          Sorry for the delay and yes, from my initial testing on centos 7, spam assassin did appear to stop and not be usable after a full server restart whilst clamav did become active after full server restart

          I think just removing clamav is a lot more involved with IW, due to dependencies involved (I tried quickly when testing and all webmail function disappeared)

          I just need to reload before I can test further, and I think it maybe a different process which is starting clamav, so my other thought would be to rename the clamav directory, which should stop clamav from been started. However, be prepared for a lot of errors/failures been listed in the logs.

          It will be next couple of days before I am back to try above, and my other thought if above does not work, maybe to stop freshclam and or stop any sigs from been loaded, so clamav starts but with no sigs, should pass all files, including infected/malware files etc

          I hope that helps a little

          Many thanks

          John

          Comment


          • #6
            Hi Nqservices
            Sorry, a thought came to me, and the following should resolve your issue over clamav starting backup after server restart
            I am not in position to test on Centos 7, but should work until IW resolve
            I hope that helps a little
            Many thanks
            John
            SSH into server and run as sudo or root
            Stop Clamav Service
            service clamd stop
            Stop CLamav from Startup
            chkconfig clamd off
            chkconfig freshclam off
            Check to make sure clamav is not shown in startup
            chkconfig --list | grep clam
            To turn clamav back on for startup
            chkconfig clamd on
            chkconfig freshclam on
            Check to make sure clamav is shown in startup
            chkconfig --list | grep clam

            Comment


            • #7
              Hi @d2d4j

              Thanks for your advice... but the problem is that this is a bug that I have already reported many months ago directly to Interworx support team and until now is not fixed. I'm not talking about a new feature, but jsut to fix the already existing feature of disable spam and virus services on boot. The button exists on IX, it just does not work.. at least in CentOS 7.

              Most of my Interworx servers only host websites so all mail services are disabled. So each time a server needs a reboot or if it goes offline to any reason, when it restarts I or my clients must manually login Interworx to disable the virus + spam services, that are the ones that consume many hardware server resources, like RAM.

              I know that I can manual disable... but and what about all my clients? What do I tell them? Hey look IX team knows about the bug for many months but they just don't care!

              Hope IX can resolve this bug soon and it will help a lot is more persons contact IX support about this to ensure they fix it. If this is not resolved soon I will stop using IX just because their support team does not cares...

              Comment


              • #8
                Hi nqservices

                Many thanks, and I do understand your frustration but I do not fully know what the issues are, that are delaying clamav from not starting up after Iw disabled in IW-CP

                I'm not even sure if my further thought would work on centos 7, as it will be a few days before I am back at my office to try sorry

                I have sent IW this thread, so hopefully will be progressed timely to resolve (it might even be worked on as I type)

                I do know every control panel has issues, some easy to resolve and some in depth, so I would ask for patience

                Do you mind me asking though, if mail is not used, there would not be much resource used by clamav (unless third party sigs have been added - sanesecurity etc...), but I take your point over the resource used

                I hope that helps a little and hopefully others may respond

                Many thanks

                John

                Comment


                • #9
                  Hi @d2d4j


                  Once again thanks for your help on this! I really hope IX team can address and resolve this bug/issue soon.

                  Originally posted by d2d4j View Post
                  Do you mind me asking though, if mail is not used, there would not be much resource used by clamav (unless third party sigs have been added - sanesecurity etc...), but I take your point over the resource used
                  Even with mail not being used, the spam + anti-virus services will take at around 400MB RAM resources. Now imagine on a VPS with 2GB RAM, this makes a real difference! And the most annoying thing is that I don't know what more I can say to my clients that are always complaining about this...

                  The ones that have un-managed services, always have to ensure to login their servers after every reboot or downtime to manually disable the spam + anti-virus... It's really a very annoying problem.

                  And onCe again, it's a feature already present in IX. The button to disable this services on boot... it just does not work on CentOS 7. For testing outside my own servers I have tested with CentOS 7 on DigitalOcean and also on a Linode VPS servers that both run KVM.

                  Thanks
                  Last edited by nqservices; 04-27-2017, 09:51 PM. Reason: typos

                  Comment


                  • #10
                    Hi nqservices

                    I'm sorry, my browser has gone funny so I will have to wait an hour before been able to update my post if alright

                    There's far too much to type using tapatalk

                    Many thanks

                    John

                    Comment


                    • #11
                      Hey nqservices,

                      I'm sorry to hear that the issues you reported are still ongoing. I found the bug reports you submitted and reconfirmed the problem. We brought the bug reports to the attention of the development team and we're looking at them now. I will update you as soon a we have more information.

                      Thanks,

                      Nathan

                      Comment


                      • #12
                        Originally posted by IWorx-Nathan View Post
                        I'm sorry to hear that the issues you reported are still ongoing. I found the bug reports you submitted and reconfirmed the problem. We brought the bug reports to the attention of the development team and we're looking at them now. I will update you as soon a we have more information.
                        Hi Nathan,

                        Thanks for your feedback and attention on this! I really appreciate and hope to see this bugs resolved on future updates.

                        Comment


                        • #13
                          Hey nqservices,

                          A fix for the Spam Assassin / clamAV auto starting issue is now in review. It looks like CentOS 7 treats run levels 2,3, and 4 the same way. For Spam Assassin and ClamAV ( and a few other services ) we used chkconfig to disable starting at boot for run level 3 only. At installation time, these services are all set to boot for run level 3,4, and 5. To work around this immediately, use chkconfig to disable starting the service at boot. For example:

                          Code:
                          chkconfig spamassassin off --level 345

                          Comment


                          • #14
                            Originally posted by IWorx-Nathan View Post
                            Hey nqservices,

                            A fix for the Spam Assassin / clamAV auto starting issue is now in review. It looks like CentOS 7 treats run levels 2,3, and 4 the same way. For Spam Assassin and ClamAV ( and a few other services ) we used chkconfig to disable starting at boot for run level 3 only. At installation time, these services are all set to boot for run level 3,4, and 5. To work around this immediately, use chkconfig to disable starting the service at boot. For example:

                            Code:
                            chkconfig spamassassin off --level 345

                            Hi Nathan,

                            Thanks for the information. I'm happy to see that your team will release a fix for this bugs on a future IX update.

                            And thanks for the advice on how to manually and temporary resolve the issue until the bug is not fixed.

                            Keep up the good work! Thanks

                            Comment

                            Working...
                            X