Announcement

Collapse
No announcement yet.

Invalid command 'SuexecUserGroup' restarting apache after adding new sites

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Invalid command 'SuexecUserGroup' restarting apache after adding new sites

    Hello,

    Since I upgraded my Interworx to 1.8.0 beta I get the following error every time I add a new website:

    Syntax error on line 3 of /etc/httpd/conf.d/my.new.site.conf:
    Invalid command 'SuexecUserGroup', perhaps mis-spelled or defined by a module not included in the server configuration

    The only way to start apache is commenting out the SuexecUserGroup line in my config but not sure if i'm doing wrong, any ideas?

    Thanks a lot!

    -mca

  • #2
    mca, are you using redhat 9?

    Could you paste the output of:

    Code:
    rpm -q httpd
    Code:
    grep suexec /var/log/httpd/error_log
    Thanks,

    Chris
    Chris Wells
    InterWorx L.L.C. | http://interworx.com
    InterWorx Control Panel

    Comment


    • #3
      I am using Red Hat Linux release 9 (Shrike) that installed sagonet by default, I haven't upgraded anything but interworx from 1.7 to 1.8


      # rpm -q httpd
      httpd-2.0.50-100.iworx


      # grep suexec /var/log/httpd/error_log
      ...this one doesn't return anything even after getting the error while trying to restart apache


      before upgrading interworx SuexecUserGroup didn't seem to be a problem on my config files.

      Comment


      • #4
        well.. i added LoadModule suexec_module modules/mod_suexec.so to /etc/httpd/conf/httpd.conf and the poblem is solved, the wierd thing is that the interworx upgrade doesn't load that module by default... anyway, can somebody explain me what's that module for please?

        Comment


        • #5
          This is the first I've seen of this with 1.8 (the LoadModule not being there) and this actually pertains to both of your problems. Per your other thread, the SiteWorx accounts aren't being created because when apache is reloaded there is an error (the suexec error).

          suexec is a wrapper script that makes CGI scripts run as the owner of the script instead of as the main webserver user. suexec is a good thing, which is why it's 'on' by default for InterWorx-CP.

          TIM RYBERG: can you confirm that there's a LoadModule for suexec in your main httpd.conf. I've checked our test boxes here and it seems to be there but I need a 3rd party to chime in.

          Btw, your fix is the right one and you should be fine now, but I want to nail down why this happened.

          Chris
          Chris Wells
          InterWorx L.L.C. | http://interworx.com
          InterWorx Control Panel

          Comment


          • #6
            Ok, this is getting wierd.

            I've got the 1.8 beta installed. I check my main httpd.conf (/etc/httpd/conf/httpd.conf) and the LoadModule line for suexec is not present. I've not encountered any errors, but after reading this thread, it sounds like it should be there. So I proceeded to add the LoadModule line for it.

            After issuing a:

            Code:
            # service httpd restart
            I get this error (but the service starts):

            Starting httpd: [Tue Aug 31 15:17:57 2004] [warn] module suexec_module is already loaded, skipping
            So, it's being loaded from somewhere, but not the main httpd.conf.

            Comment


            • #7
              Thanks for the post sonicgroup.

              It's being loaded from the iworx.conf in /etc/httpd/conf.d/iworx.conf in pre 1.8 versions, scinet can you paste your /etc/httpd/conf.d/iworx.conf in here when you get a sec.

              Chris
              Chris Wells
              InterWorx L.L.C. | http://interworx.com
              InterWorx Control Panel

              Comment


              • #8
                my /etc/httpd/conf.d/iworx.conf:

                ##
                # InterWorx Apache Supplement
                ##

                ##
                # Enable CGIs
                ##

                AddHandler cgi-script .cgi
                AddHandler cgi-script .pl

                ##
                # setup the basic redirects
                ##

                RewriteEngine on
                RewriteRule ^/siteworx(/)?$ https://%{HTTP_HOST}:2443/siteworx/\?domain=%{HTTP_HOST} [R,L]
                RewriteRule ^/nodeworx(/)?$ https://%{HTTP_HOST}:2443/nodeworx/ [R,L]
                RewriteRule ^/webmail(/)?$ https://%{HTTP_HOST}:2443/webmail [R,L]

                Comment


                • #9
                  scinet,

                  Ok, I'm going to check this out. Short answer is that you're fine doing what you did to fix, so you can continue "normally" from here on out.

                  Chris
                  Chris Wells
                  InterWorx L.L.C. | http://interworx.com
                  InterWorx Control Panel

                  Comment

                  Working...
                  X