Announcement

Collapse
No announcement yet.

nodeworx session time logged in

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • nodeworx session time logged in

    Hiya,
    Not sure if it is called session login time, but I was modifying/comparing my CSF settings with other server, hit save and bang all black screen and it seemed I was logged out... Is there somewhere a setting to make it last longer?
    Being 'old and slow' seems more than ever a handicap....
    Thanks,
    Nico

  • #2
    Hi nico

    I am sorry, IW use APF I think from memory, but it is early after a late night

    It sounds more likely in any event, that you have locked yourself out on firewall and not a session issue

    I would ssh into server and stop firewall then see if you can access IW again

    Many thanks

    John

    Comment


    • #3
      Hi John,
      It has nothing to do with APF or CSF, same happens if you login nodeworx and do nothing for [n] minutes, come back and then you have to login again, it is that setting :-)
      Kind regards,
      Nico

      Comment


      • #4
        Hi nico

        Manu thanks

        The strange thing I have never had to change any session timer in IW

        I will check though when back

        One thing comes to mind though, do you have any cron running which would delete the sessions

        Many thanks

        John

        Comment


        • #5
          I haven't changed anything in cron, I have attached the screen-shot of it, you see something what is responsible for it or is it a browser setting somehow?

          Comment


          • #6
            Hi Nico

            Many thanks

            Sorry I was thinking of timewatch to clear down /tmp files say after 12 Hours (or what ever value you stipulate)

            I would go very careful with what I am going to ask you to do, and do not make any other changes except for this 1 change. Infact, when you edit the file it gives you a big warning to not edit this file

            Could you SSH into your server and run as root or su

            vi ~iworx/iworx.ini

            locate the following (its towards the very end of the file)

            [session]
            life="0"

            if not 0 change to 0

            save (press esc key and type :wq)

            service iworx restart

            Please take note though of the number shown in life="" incase it makes no difference, and you can revert back if you wish (0 means no session expiry)

            Has this resolved your session expiry in IW-CP

            As last warning, if you mess around with the iworx.ini you can stop or cause issues which IW may charge if you want it corrected.

            Many thanks

            John

            Comment


            • #7
              Hi John,
              Thanks ever so must [again] for your very well explained instructions!
              The setting was already 0, so I though let's give it 14400 assuming it is in seconds, restarted iworx and now I have to wait again....
              I won't make any changes in that file unless I am instructed as I don't want to mess the system up, thanks for the warning.
              Kind regards,
              Nico

              Comment


              • #8
                Hi nico

                Many thanks

                Iím sorry I am little confused. Is it working normally now

                If it is not, a few things Iím thinking about (session expiry in browser is not issue I believe as it takes instructions from server side)

                Did you run service iworx restart

                Are you drives nearly full

                Is /home/interworx/tmp I think it is full

                Is /home/interworx/var/sessions full

                Are perms correct on those folder

                Have you run varpermsfix.pex

                Have you restarted server

                The issue coming to mind though, is you said you were changing something in firewall and issue happened when you clicked save.

                Please could I ask what you changed

                Have you tried from a different external IP address/connection to make sure you have not blocked yourself out

                Many thanks and have a lovely weekend

                John

                Comment


                • #9
                  Hi John, tried everything you suggested but no result, I then update to Beta and it works...

                  This is what it looks now in the iworx.ini file
                  [session]
                  idle_timeout="14400"
                  life="0"

                  Kind regards,
                  Nico

                  Comment


                  • #10
                    This information has been great for me.

                    Comment


                    • #11
                      gise35 Hi, would you mind to share what it did for you?
                      Last edited by Nico; 08-20-2019, 05:25 PM.

                      Comment


                      • #12
                        Hi nico

                        Many thanks and glad itís working for you

                        Not too sure why those 2 values work for you sorry

                        The other poster is perhaps a spammer. It seems a strange post which some just post to build up a post score then amend their posts.

                        I hope I am wrong though so apologies in advance

                        Many thanks

                        John

                        Comment


                        • #13
                          d2d4j Hi John,
                          I think you might be quite right, I have seen that happen on many forums, not sure what would be the benefit for us normal users as it take so much more time to go through this to find the real important information.

                          To come back on the issue, do you think that the extra line is doing it or the upgrade to Beta, I have only one VPS to work with at the moment. I think you mentioned you had a few, perhaps you could test to make sure it is the extra setting so I can keep it on stable. Thank you.
                          Kind regards,
                          Nico

                          Comment


                          • #14
                            Hi nico

                            Many thanks

                            I think that the beta upgrade replaced a file/files which then brought it to working normally myself.

                            If your now in beta, you cannot downgrade to RC or stable. There should have been a warning on the upgrade box

                            It may have changed though, sorry but I believe I am correct

                            Many thanks

                            John

                            Comment


                            • #15
                              d2d4j
                              Hi John,
                              I can't remember a warning, but I knew the risk :-), it is not production yet, I will build a new one with your recommendations in stable
                              Kind regards,
                              Nico

                              Comment

                              Working...
                              X