Announcement

Collapse
No announcement yet.

NodeWorx and SiteWorx Control Panels Not Loading

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • NodeWorx and SiteWorx Control Panels Not Loading

    Hi,

    I just upgraded my Interworx license via my reseller. The license would not update to the 35 domain license I purchased, it keep the banner at the top showing the 10 domain license. So I was told to restart Interworx, which no one could tell me how to do, so I rebooted my server. Now, I cannot log in to any Nodeworx or Siteworx control panels. The hosted web sites load, and when I enter my IP address in a browser I get the Interworx Test Page for Apache. When I click the Nodeworx link to log in, it does not load, no errors or notices.

    Anyone have any ideas?? I have SSH access and have tried to re-install Interworx and that didn't work either.

    Any help would be great - thanks.

  • #2
    Hi Hostpanda
    Welcome to interworx forums
    To be honest, your first call should be to your reseller.
    However, what is your distro, IW version and is this a VPS or full dedicated server
    What do you see if you reference your IW-CP using IP address - https://123.456.789.123:2443/nodeworx (where 123.456.789.123 is your server Ip address
    If nothing shows, ssh into server, run as root or su service iworx restart
    I hope that helps
    Many thanks
    John

    Comment


    • #3
      John

      thank you, the restart worked. By the way, I did contact my reseller, but needed a quicker response.

      Quick question, I upgraded my license to the 35 domain license, but it still shows 10 domain. Can you check that for me and why its not updating?

      Thanks

      Comment


      • #4
        I take it you are with Demlimier or whatever they are called :)Use the following to change your license key:

        You can update it by going to NodeWorx > Server > Settings > License Key and save. Then run the below command:~iworx/cron/license.pex --sync This will update the license server.

        For SSH Fans go to: nano /home/interworx/iworx.ini and then find Ctrl + W put KEY= and edit the key=LicenseKEY then simply run the command: ~iworx/cron/license.pex --sync
        Michael Dance
        Licensecart Certified Distribution for Blesta, Interworx, KernelCare, CraftSRV, Softaculous, SolusVM, LiteSpeed & SSLs.
        Free Softaculous & 50% off KernelCare with every InterWorx license bought with us. We pride ourselves by being the cheapest External provider.
        Need Help? Check out the InterWorx FAQs or check out our Knowledgebase. In the InterWorx family, you're never alone!

        Comment


        • #5
          Hi Licensecart

          Thanks for info. However it did not work --

          Comment


          • #6
            Hi hostpanda

            Glad it's back working for access.

            Mikes post should update licence and if it fails, you need to check that your server can reach the license servers.

            Do you get an error when you run licence.pex as per mikes post

            If not, then please make sure your time/date is correct and retry

            If all does not error and is correct, I'm thinking it is browser cache - so can you delete your browser cache and confirm if this then shows as you expect

            Many thanks

            John

            Comment

            Working...
            X