Announcement

Collapse
No announcement yet.

reverse DNS (PTR) question

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • reverse DNS (PTR) question

    Hi
    setting up a new dedicated server but have a probem with reverse dns, checks show No reverse DNS (PTR) entries.
    The reverse host nameservers have been added at the servers data center but they have requested for me to add the host nameservers to my zone file.
    not had to do this before, where do i add them? is this the correct way?

    any help appreciated
    Thank you
    Gary T

  • #2
    Hi Bear

    Good question

    Please see pics to help, but login to nodeworx, system services, dns, zones and click edit record on domain you need PTR (PTR is RDNS), click add and complete all detail (IP address etc...)

    I think normally unless you have a large CIDR range, PTR is usually with provider, but not always

    Many thanks

    John
    Attached Files

    Comment


    • #3
      Sorry for the late reply, thank you for a reply appreciated.

      still having issues with RDNS, my ISP have added the hostname records for each ip address and I added PTR record as they instructed to my zone.
      I usually use intodns.com to check my dns but cannot resolve this error,

      ERROR: No reverse DNS (PTR) entries. The problem MX records are:
      #.#.#.95.in-addr.arpa -> no reverse (PTR) detected

      usually I just send my hostnames serv.mydomain.com etc. to my ISP and never add a PTR record and all runs ok with no errors.
      Attached Files
      Gary T

      Comment


      • #4
        Hi Bear
        I think you may notbe fully understanding, or your ISP/provider of IP addresses are not understanding (or from the looks of it, not correctly set the PTR (Rdns) on the IP addresses as you requested)
        The question to answer to determine this is
        Have the PTR been delegated to you (yes/no)
        if yes, you set the PTR as shown above (it should work lovely)
        if no, your ISP/provider has to set the PTR (you do not have to set any PTR records)
        I hope that helps a little, but just a small point to note, on some test websites, they cache the result, so you have to wait a period of time, usually 24 hours before correct result is available - not all test websites do cache results though
        Many thanks
        John

        Comment


        • #5
          I think John is right about who (and where) is responsible for the PTR record. If reverse DNS is setup at the ISP and you're hosting your own DNS, your zone doesn't need a PTR record. That gets done along with your rDNS request at the ISP. You may want to include a v6 address if you're using IPv6.

          Comment


          • #6
            this is the first time I have had this issue, usually the provider adds the PTR and that's sorted.
            asked the provider and they say they have been added but will check with them again as I feel they have not been added

            my providers control panel have in server management option for adding and submitting your reverse record. just type in the hostname and save.
            I name mine serv.domain.co.uk, serv1.domain.com and so on to the hostname record.

            Thank you for your replies
            Gary T

            Comment


            • #7
              Hi bear

              Just a thought, as I do not know your providers control panel sorry - but are you sure it is for creating PTR records

              If it is, then it is the first time I have heard of a provider allowing PTR to be set without delegation, even in a provider control panel

              I could be entirely wrong though, so please forgive me

              Many thanks

              John

              Comment


              • #8
                screen capture of what I am setting, this is the second provider that I have seen this option
                Attached Files
                Gary T

                Comment


                • #9
                  Hi bear

                  Many thanks.

                  I did apologise if I was wrong so guessing here in uk, we maybe behind a little

                  It certainly does look like you can set PTR

                  However, it does not mean it is working correctly as your rdns test shows it has not been set

                  I would open a support ticket with your provider stating what you have done, with rdns test you have and ask them to confirm their own rdns test externally. It should fail and allow them to fix/set your rdns record

                  I hope that helps

                  Many thanks

                  John

                  Comment


                  • #10
                    I am in the UK also, two companys I have been with have this option, the last one was very good and well thought out.
                    Gary T

                    Comment


                    • #11
                      Hi bear

                      Many thanks

                      We are with pulsant and their CP does not have that option

                      Your is the first I have ever seen, unless it was my eyes not seeing the option - which is very possible

                      Many thanks

                      John

                      Comment


                      • #12
                        finally sorted by my provider, senior tech team have now made some internal changes which have enabled the rDNS records to resolve.
                        Gary T

                        Comment


                        • #13
                          Hi bear

                          Excellent news

                          Was it broken in CP or did they just add the rdns themselves

                          Many thanks

                          John

                          Comment


                          • #14
                            I don't really know, all they said was they made some adjustments so it resolved correctly.
                            still sorted now, must have caused a lot of emails to fail as they are flooding in now
                            Gary T

                            Comment

                            Working...
                            X