Announcement

Collapse
No announcement yet.

Pointer Domains

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Pointer Domains

    I'm having an issue with pointer domains. I'm getting the message

    Error: Both domains already exist, unable to create alias

    When I try to create on on an account. I haven't tried any other accounts yet. Any ideas?

    This occurred after I deleted a siteworx account whith them in and then created a new one. {I'd messed some things up in configuration and fitured the easiest way to fix it was to start over.}

    I've tried restarting http and some of the other services and even rebooting the server. Any suggestions?

    Tim

  • #2
    Hi Tim,

    We're aware of this bug, and it will be fixed in the next release. Here's the workaround:

    1) Delete the SiteWorx account in question.

    2) Log in to your server as root, and for each of the pointer domains that were set up to point to the SiteWorx account that was deleted, execute this command at the shell:
    ~vpopmail/bin/vdeldomain the-pointer-domain.com
    For example, if you had the SiteWorx account mydomain.com, and mydomain.net and mydomain.org were set up to point to mydomain.com, execute these commands as root:

    ~vpopmail/bin/vdeldomain mydomain.net
    ~vpopmail/bin/vdeldomain mydomain.org
    Then you can re-create the SiteWorx account, and this problem won't happen.
    Paul Oehler
    InterWorx-CP | http://interworx.com
    InterWorx Control Panel

    Comment


    • #3
      Thanks Paul, works like a charm. :)

      Comment


      • #4
        Is this the same problem when getting the error "Neither 'domain.com' or 'domain.net' exist, unable to create alias."? I was trying to add a domain.net pointer to the domain.com Siteworx account. I had already used the vdeldomain for vpopmail since I won't be hosting email for this account. Trying to figure out why I can't add a pointer to it now.

        Comment


        • #5
          The email functionality is needed in order to add a pointer domain. You'll need to:

          ~vpopmail/bin/vadddomain domain.com test

          and then add the pointer domain and then vdeldomain it again
          Greg Swaney
          gswaney@nexcess.net
          NEXCESS.NET Internet Solutions
          http://nexcess.net

          Comment


          • #6
            Thanks! That worked.

            Comment

            Working...
            X