Announcement

Collapse
No announcement yet.

WordPress blank pages

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • WordPress blank pages

    Hello,

    We have a customer reported problems with installing WordPress on one of our servers this morning. This is a PHP4.3.11/Mysql4/Iworx box, running FC3.

    I tried an installation both through scriptworx and manually and neither of them work. Just a 'blank' page and sometimes some stupid errors in the sites error log. However, installating through Scriptworx on our FC4 box went through perfectly.

    The errors being recieved are along the lines of:
    21: [Sun Aug 20 12:03:20 2006] [warn] [client xxx.xxx.xxx.xxx] mod_include: Options +Includes (or IncludesNoExec) wasn't set, INCLUDES filter removed

    I have done a fair bit of reading this morning, and cant find very much of use, so was wondering if anyone here had experienced a similar issue?

    Strange that two Iworx boxes act in two completely different way

    Thanks!
    Ledger Technologies Group Ltd - UK based dynamic group of companies that utilises existing and emerging technologies to provide data solutions for clients globally.
    EverythingWeb.Net Ltd - UK Based Website Hosting, Design & Maintenance.

    The views expressed in the above messsage are purely my own and are in no way official or representative of the companies I represent.

  • #2
    Did you get to the install wizard on the manual installtion of it? Or does that end up with a blank page too?

    If it's installed, and then not working, try disabling the permalink structure, if it's enabled - so instead of posts being like yoursite.com/2006/08/new-post, they look like yoursite.com/index.php?id=1

    Are all the errors like that? Could you paste more, if they're at all different?

    This seems more like a wordpress bug than a siteworx one too - perhaps someone should move it ;)

    Comment


    • #3
      Hi Fr3d,

      Its balking on step2 of the install. I believe it to be something to do with how apachace is configured, or similar.

      There are no errors being outputted to the screen - it is acting almost as if its not generating anything at all.

      With regards to disabling the permalink structure - I presume through Wordpress's admin interface - which doesn't load. Do you know if there is a database flag taht can be set to disable it directly?

      Cheers.
      Ledger Technologies Group Ltd - UK based dynamic group of companies that utilises existing and emerging technologies to provide data solutions for clients globally.
      EverythingWeb.Net Ltd - UK Based Website Hosting, Design & Maintenance.

      The views expressed in the above messsage are purely my own and are in no way official or representative of the companies I represent.

      Comment


      • #4
        Permalinks should be disabled by default on a clean install.

        Why don't yuo try using Wordpress 2 instead of the 1.5 that Scriptworx has?

        Are there any .htaccess files in any folders above the one wordpress is in?

        Comment


        • #5
          This error occurs with the scriptworx installation AND when I manually installed the latest version from WordPress :(

          No, no other htaccess files - it's a rather strange issue. :S
          Ledger Technologies Group Ltd - UK based dynamic group of companies that utilises existing and emerging technologies to provide data solutions for clients globally.
          EverythingWeb.Net Ltd - UK Based Website Hosting, Design & Maintenance.

          The views expressed in the above messsage are purely my own and are in no way official or representative of the companies I represent.

          Comment


          • #6
            Not sure if this is related or not but I've seen a *similar* problem before. Are you able to access the login page, http://domainname.com/wordpressfolder/wp-login.php

            If you are, then login and change the default template to another template and see if that fixes it. If you're not, I have no idea ;)
            Greg Swaney
            gswaney@nexcess.net
            NEXCESS.NET Internet Solutions
            http://nexcess.net

            Comment


            • #7
              That won't work Greg, as he said he can only get to step 2 of the installer.

              EverythingWeb, what extensions do you have loaded in PHP?

              Comment


              • #8
                Hi Fr3d,

                PHP Info: http://www.ew-falcon.net/php.php
                Ledger Technologies Group Ltd - UK based dynamic group of companies that utilises existing and emerging technologies to provide data solutions for clients globally.
                EverythingWeb.Net Ltd - UK Based Website Hosting, Design & Maintenance.

                The views expressed in the above messsage are purely my own and are in no way official or representative of the companies I represent.

                Comment


                • #9
                  Fresh installation through ScriptWorx: http://www.ew-falcon.net/wp/
                  Ledger Technologies Group Ltd - UK based dynamic group of companies that utilises existing and emerging technologies to provide data solutions for clients globally.
                  EverythingWeb.Net Ltd - UK Based Website Hosting, Design & Maintenance.

                  The views expressed in the above messsage are purely my own and are in no way official or representative of the companies I represent.

                  Comment


                  • #10
                    Greg, I'm getting all sorts of weirrd probs with this, and no can't get login page to come up.

                    Its just not having it. :(
                    Ledger Technologies Group Ltd - UK based dynamic group of companies that utilises existing and emerging technologies to provide data solutions for clients globally.
                    EverythingWeb.Net Ltd - UK Based Website Hosting, Design & Maintenance.

                    The views expressed in the above messsage are purely my own and are in no way official or representative of the companies I represent.

                    Comment


                    • #11
                      This is a tough one! :p

                      I would suggest trying to narrow down everything to isolate the problem - revert configurations to defaults (after backing up your custom ones), create a clean account to test on, etc.

                      Also, try looking through the step 1 and 2 of the installer and see what it's actually trying to do! And look through all the wordpress files and see if there's anything that's turning off PHP sending error messages.

                      I know I asked about .htaccess files before, but is there one in the Wordpress folder? With the normal Wordpress Permalink mod_rewrite stuff? If there is, try deleting it - It has a knack for being really annoying when something breaks!

                      Comment


                      • #12
                        Morning Fr3d,

                        Yeah tell me about it being tough!!

                        There is no .htaccess file at all in the Wordpress directory - there isn't one created when the package is installed with Scriptworx etc.

                        I am sure it has something to do with this line in the error log:
                        mod_include: Options +Includes (or IncludesNoExec) wasn't set, INCLUDES filter removed

                        but its just finding what's causing it :(
                        Ledger Technologies Group Ltd - UK based dynamic group of companies that utilises existing and emerging technologies to provide data solutions for clients globally.
                        EverythingWeb.Net Ltd - UK Based Website Hosting, Design & Maintenance.

                        The views expressed in the above messsage are purely my own and are in no way official or representative of the companies I represent.

                        Comment


                        • #13
                          After much hunting and hair pulling, we found the error. I *believe* it could be something to do with the manual upgrade on the box of MySQL from 3.23 to 4.x.x. The following code needed changing in wp-includes/wp-db.php

                          ORGINAL:
                          Code:
                             while ($i < @mysql_num_fields($this->result)) {
                                           $this->col_info[$i] = @mysql_fetch_field($this->result);
                                           $i++;
                                       }
                                       $num_rows = 0;
                                       while ( $row = @mysql_fetch_object($this->result) ) {
                                           $this->last_result[$num_rows] = $row;
                                           $num_rows++;
                                       }
                          CHANGETO:
                          Code:
                             while ($i < @mysql_num_fields($this->result)) {
                                           $this->col_info[$i] = @mysql_fetch_assoc($this->result);
                                           $i++;
                                       }
                                       $num_rows = 0;
                                       $this->result = @mysql_query($query,$this->dbh);
                                       while ( $row = @mysql_fetch_object($this->result) ) {
                                           $this->last_result[$num_rows] = $row;
                                           $num_rows++;
                                       }
                          Being as this works perfectly one one of our other servers, I am pretty sure its a config issue with this particular server.

                          We have since updated the InterWorx package that it uses to install WordPress to include the changes so all is well now. But I thought I would update this thread just in case anyone else experiences this.

                          Cheers,
                          William :)
                          Ledger Technologies Group Ltd - UK based dynamic group of companies that utilises existing and emerging technologies to provide data solutions for clients globally.
                          EverythingWeb.Net Ltd - UK Based Website Hosting, Design & Maintenance.

                          The views expressed in the above messsage are purely my own and are in no way official or representative of the companies I represent.

                          Comment


                          • #14
                            try this:

                            Create a .htaccess file with the following in it:
                            Code:
                            php_value memory_limit 16M
                            Then put it in your website root, solved the problem here with some customers.

                            -Rámon

                            Comment


                            • #15
                              Rámon,

                              Thanks for the tip. We actually have the server set to 32M globally so it can't be that unfortunately :(

                              I am still sarching for a more 'concrete' solution as it has something to do with the way that PHP is compiled against MySQL, as per this PHP Bug: http://bugs.php.net/bug.php?id=31288

                              Cheers,
                              William
                              Ledger Technologies Group Ltd - UK based dynamic group of companies that utilises existing and emerging technologies to provide data solutions for clients globally.
                              EverythingWeb.Net Ltd - UK Based Website Hosting, Design & Maintenance.

                              The views expressed in the above messsage are purely my own and are in no way official or representative of the companies I represent.

                              Comment

                              Working...
                              X