Announcement

Collapse
No announcement yet.

Any one have issues with the Mac iweb and seeing , ’ characters?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Any one have issues with the Mac iweb and seeing , ’ characters?

    I have some one using iweb, Mac program, on my IW 3.0.4 CentOS 4.7 server. After uploading their html page they are getting these , ’ characters. The html pages that are being uploaded are using "charset=UTF-8"

    In my research I did run across this Mac page addressing this issue http://homepage.mac.com/thgewecke/iwebchars.html

    Here is a statement from that page
    If a page you create in iWeb and publish to a server other than .Mac contains strange unwanted characters, try setting View > Text Encoding in your browser to UTF-8. If this makes it appear correctly, it means your server is probably forcing browsers to interpret the page as being in Latin-1 encoding. iWeb pages are in UTF-8 encoding so that they can accomodate all languages, not just English and those of W. Europe, and there is no practical way to change this.
    Well I tried that and the , ’ characters went away.

    Now since this is a server setting issue, does anyone know where to go to make a change server wide to allow UTF-8 without effecting other sites settings.

    OR

    Would this best be done with a .htaccess for this one particular web site?

    Thanks guys for any and all help.
    Roy
    Roy
    KARTHOST.com
    [ KARTHOST Facebook FAN Page ]
    [ Follow KARTHOST on Twitter ]
    WordPress Training - KartHost University

  • #2
    With some further research I found this page http://www.w3.org/International/ques...access-charset that address's this issue.

    So, now my question is, if you had this problem what did you do, set up a .htaccess file for that specific SiteWorx site, or change the setting server wide to allow UTF-8 to be used server wide?

    If server wide, what file did you change?
    Roy
    KARTHOST.com
    [ KARTHOST Facebook FAN Page ]
    [ Follow KARTHOST on Twitter ]
    WordPress Training - KartHost University

    Comment


    • #3
      I would suggest the .htaccess route - you may cause issues with other sites expecting the current default if you change it server wide.

      Charsets are such a nightmare...but standardizing is nearly impossible too!

      Comment


      • #4
        Originally posted by IWorx-Tim-Pgh View Post
        I would suggest the .htaccess route
        I will give .htaccess a try for this site, thanks Tim.
        Roy
        KARTHOST.com
        [ KARTHOST Facebook FAN Page ]
        [ Follow KARTHOST on Twitter ]
        WordPress Training - KartHost University

        Comment


        • #5
          I attempted to use the Directory Options function in SiteWorx, (specified a directory) and used the Default Character Set to set the following Default Character Set "UTF-8 .html" and got a error, invalid, then tried "UTF-8 html" without the dot and same error. Could only use "UTF-8"

          So I set it as UTF-8 and nothing changed on the problem pages. So I manually changed the .htaccess to UTF-8 .html and still no luck.

          Anyone else that might have had these same issues and you found a solution, I would love to hear from you.

          I will continue to work this problem.
          Roy
          KARTHOST.com
          [ KARTHOST Facebook FAN Page ]
          [ Follow KARTHOST on Twitter ]
          WordPress Training - KartHost University

          Comment

          Working...
          X