Announcement

Collapse
No announcement yet.

default sites with https not work

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • default sites with https not work

    Hello,

    Default sites work only http://

    example:
    http://ok.eu- ok
    https://ok.eu- other website (why?)

    What is the problem?

    kovanorby
    Last edited by kovanorby; 11-21-2015, 05:15 AM.

  • #2
    Hi kovanorby

    Welcome to interworx forums

    Have you turned on SSL and set a SSL cert on the siteworx account, hosting, domains, SSL

    Many thanks

    John

    Comment


    • #3
      The problem is that if you do not set ssl, it opens up other website. not the basic website that has been set

      Comment


      • #4
        Hi kovanorby

        Sorry, that is the nature of SNI.

        If you do not want this to happen, then you need to assign a static IP to the site

        IW are aware of the SNI https issue but a fix I think is harder then it first appears.

        I thought your post was SSL not working or I would have answered as I have now

        Glad your SSL is working anyway and you can set a self generated SSL on any siteworx domain which makes it work, but for those without SSL will default to the first alpha named siteworx, such as 111.com etc

        I hope that helps

        Many thanks

        John

        Comment


        • #5
          Hi,

          ok, thank you.


          if it is solved at http, https, than why not? (IP Management ▷ Default Sites)
          Last edited by kovanorby; 11-21-2015, 05:15 AM.

          Comment


          • #6
            Hi kovanorby

            Good idea but I'm not privy to IW thinking

            I have just run a few checks based on your posted domain, which firstly, love your site for gamers, but you have serious issues over SSL

            kn1.eu does not have SSL enabled whereas your game website does, but a test shows possible issues with SOA and MX, mx you may not want but SOA is important, although I see your NS are with cloudflare

            Also, you may want to adjust your ciphers as your showing SSLv3 and RC4 available for use

            I hope that helps a little more

            Many thanks

            John

            Comment


            • #7
              Sorry, I can be slow at times

              Your idea over controlling https at IP management would only work if if a users tried referencing your server using IP address and not domain name I believe

              Still a good idea though

              Many thanks

              John

              Comment


              • #8
                Temporarily solved by using self ssl, with all domain.

                Thanks for your help, and sorry for my bad english :)

                kovanorby

                Comment

                Working...
                X