Announcement

Collapse
No announcement yet.

SiteWorx: Unable to find fpm package for php

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • SiteWorx: Unable to find fpm package for php

    Hi all,

    When you log into a siteworx account where you would see what their server usage is there is a pink message at the top saying: Unable to find fpm package for php"

    Any ideas if an update has broken something? We are on: InterWorx-CP v6.0.13

  • #2
    Hi Bertie

    I would update IW to 6.0.22 and see if this is resolved

    If it is not, there is a fpm.php pex which can be run to rescan php fpm

    I would need to look for the exact pex name but I have resolved a similar issue on one of our servers which lost fpm

    It might of course be something totally different sorry

    I hope that helps

    Many thanks

    John

    Comment


    • #3
      Have updated Interworx but problem still there. Can't even get to the web server section without that error popping up. If you could let us know the right command to try the pex file and I'll give that a shot.

      Comment


      • #4
        Hi Bertie
        Many thanks
        Please use the following in order but test after each first (you may not need to run them all)
        Please be careful running modify-www-conf option, it will change conf settings
        it could be that php-fpm is not running, so please try the following first
        service php56-php-fpm restart
        service php70-php-fpm restart
        service php71-php-fpm restart
        service php72-php-fpm restart
        Please do not worry if any fail, it probably means those php-fpm versions are not installed
        Lastly, to be sure, have you turned on php-fpm multi
        I hope that helps a little, but if this does not resolve your issue, please open a support ticket and appreciate if you could update post with resolution when resolved
        Many thanks and good luck
        John
        Please note you use these commands at your own risk - I do not accept any liability for loss/damage etc if you use them.
        ./php-fpm.pex --list-installed-versions
        ./php-fpm.pex --restart-fpm
        ./php-fpm.pex --list-versions
        ./php-fpm.pex --restart-fpm
        ./php-fpm.pex --refresh-available-versions
        ./php-fpm.pex --restart-fpm
        ./php-fpm.pex --modify-www-conf
        ./php-fpm.pex --restart-fpm

        Comment


        • #5
          Hey guys,

          I had the same problem on one server today. After trying to install a LE certificate the website was suddenly down and I got the same error as Bertie (This happened in front of a customer - damn you Murphy's law)
          My Interworx is version InterWorx-CP v6.0.26

          I tried restarting Apache, then php, then the whole server but nothing helped. Like Bertie I even could not open Nodeworx -> System Services -> Webserver, it would show the same "Unable to find fpm package for php" instead of the settings.
          Back in the office I tried many things but nothing helped. But the last two things I did before it finally worked again was updating Iworx to the latest beta v6.0.27 and restarting each and every php version via service php54-php-fpm restart, service php55-php-fpm restart and so on
          I'm not sure what did the trick, since I did restart php71 before (the site in question is running php71). So I guess the update had something to do with it too.

          I'm just noting this down here, in case anybody else has a similar issue and finds this useful as a starting point.

          Cheers
          Michael

          Comment


          • #6
            Hi Michael

            I hope your well

            Sorry to hear that, my issue was on an old v5 I think when updating v6 and multiphp

            The beta should not be used in production servers and I donít think it can be reversed to RC

            Do you have many sites running on it

            I think it maybe php-fpm had stopped but Bertie has not posted if fixed/resolves and how it was resolved. Hopefully he may post

            Many thanks

            John

            Comment

            Working...
            X