Announcement

Collapse
No announcement yet.

Dreamweaver and InterWorx

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Dreamweaver and InterWorx

    If any of you are familiar the web design software Dreamweaver, what is the proper publishing settings for a default SiteWorx site?

    I do not use Dreamweaver, and although I have many customers that use it without problem I am having a customer that is really butchering the file system, and I am trying to figure out what he is doing wrong.

    Thanks for any feed back.
    Roy
    KARTHOST.com
    [ KARTHOST Facebook FAN Page ]
    [ Follow KARTHOST on Twitter ]
    WordPress Training - KartHost University

  • #2
    Our WebDevelopment guys use the following settings:

    Access: FTP
    FTP Host: ftp.domain.com
    Host Directory: /public_html/
    Login: ftp@domain.com
    Password: ******* Save (Ticked)

    Use passive FTP - Unticked
    Use firewall - Unticked
    Use SFTP - Unticked

    -- Change the below to personal pref --
    Maintain sync info - Ticked
    Auto upload files on save - Unticked
    Ledger Technologies Group Ltd - UK based dynamic group of companies that utilises existing and emerging technologies to provide data solutions for clients globally.
    EverythingWeb.Net Ltd - UK Based Website Hosting, Design & Maintenance.

    The views expressed in the above messsage are purely my own and are in no way official or representative of the companies I represent.

    Comment


    • #3
      I'm a huge fan of Dreamweaver.

      Personaly I find FTP has to be in "Active" mode to work with my Iworx Fedora C4 server. (As EverythingWeb suggested)

      Comment


      • #4
        Thank you guys, I will have them try that settings, slightly dofferent from what I have been telling them, mainly the
        Host Directory: /public_html
        I will get them to add the trailing "/".

        As always I appreciate you guys and the feed back I get here.
        Roy
        KARTHOST.com
        [ KARTHOST Facebook FAN Page ]
        [ Follow KARTHOST on Twitter ]
        WordPress Training - KartHost University

        Comment


        • #5
          Either /public_html/ OR: domain.com/html/
          Ledger Technologies Group Ltd - UK based dynamic group of companies that utilises existing and emerging technologies to provide data solutions for clients globally.
          EverythingWeb.Net Ltd - UK Based Website Hosting, Design & Maintenance.

          The views expressed in the above messsage are purely my own and are in no way official or representative of the companies I represent.

          Comment


          • #6
            Originally posted by EverythingWeb View Post
            Either /public_html/ OR: domain.com/html/
            Thanks, I do appreciate it!
            Roy
            KARTHOST.com
            [ KARTHOST Facebook FAN Page ]
            [ Follow KARTHOST on Twitter ]
            WordPress Training - KartHost University

            Comment


            • #7
              When Im build sites on DW I usually dont use the /public_html directory just so I can have access to non web directories specifically for the purpose of having an include directory that can not be reached directly via browsers (better security).

              Also, on some sites I have enabled SFTP via SSH (I do not enable regular shell) so that I can use the secure FTP via DW.
              [ JUSTIN ]
              [ OFF unit ]
              [ WEB DESIGN / DEVELOPMENT, GRAPHIC DESIGN, OTHER STUFF
              ]

              Comment


              • #8
                How do you enable SFTP (without shell) under Interworx?
                DomainSwede.com

                Twitter

                Comment


                • #9
                  This thread has some more info on ProFTPD SSL and SFTP
                  http://interworx.com/forums/showthre...highlight=SFTP

                  Originally posted by Justec View Post
                  For some reason I thought Iworx did this already, but I guess not.
                  I agree completely, but I figured out a way that works on RH9 to allow only SFTP access with out regular shell access. Just set the user shell from /sbin/nologin to /usr/libexec/openssh/sftp-server for the user you want to give SFTP access to.
                  This also works for me since I moved to CentOS. This will only give them SFTP and no shell. Dont remember where i found this, but it works :)
                  [ JUSTIN ]
                  [ OFF unit ]
                  [ WEB DESIGN / DEVELOPMENT, GRAPHIC DESIGN, OTHER STUFF
                  ]

                  Comment


                  • #10
                    Thanks, after asking in this thread I did a search and found just that thread - sorry about that.

                    Though, adding SFTP-support will break if an update is made on ProFTPD, right?!
                    DomainSwede.com

                    Twitter

                    Comment


                    • #11
                      Originally posted by Henrik View Post
                      Thanks, after asking in this thread I did a search and found just that thread - sorry about that.

                      Though, adding SFTP-support will break if an update is made on ProFTPD, right?!
                      They are two different things. Adding SSL to ProFTPD will break when there is and update and you will have to reinstall it (unless this has been fixed now or Iworx is now doing SSL over FTP out of the box).

                      SFTP is done over the SSH protocal and thats why you have to enable the FTP on the shell account. The login for SFTP is NOT controlled by SiteWorx but is just that accounts shell name, which should be the first 8 letter of the domain name.

                      DW does NOT work with SSL over FTP, but rather SFTP. Hope that cleared it up, if not just post in this thread again and I will try to answer any questions you have.
                      [ JUSTIN ]
                      [ OFF unit ]
                      [ WEB DESIGN / DEVELOPMENT, GRAPHIC DESIGN, OTHER STUFF
                      ]

                      Comment


                      • #12
                        Originally posted by Justec View Post
                        When Im build sites on DW I usually dont use the /public_html directory just so I can have access to non web directories specifically for the purpose of having an include directory that can not be reached directly via browsers (better security).

                        Also, on some sites I have enabled SFTP via SSH (I do not enable regular shell) so that I can use the secure FTP via DW.
                        I fully understand, however for beginners, newbs, it seems even using the remote directory of any kind is almost a challenge that many can't achieve very quickly. :(

                        Twice this week I had to reinstall a site because a user using FrontPage (using the built in FrontPage FTP) completely butchered the file structure

                        For those I just manually set up the FTP account so that it logs directly into the html directory, in SiteWorx, this is a very nice feature.
                        Roy
                        KARTHOST.com
                        [ KARTHOST Facebook FAN Page ]
                        [ Follow KARTHOST on Twitter ]
                        WordPress Training - KartHost University

                        Comment


                        • #13
                          Originally posted by Justec View Post
                          SFTP is done over the SSH protocal and thats why you have to enable the FTP on the shell account. The login for SFTP is NOT controlled by SiteWorx but is just that accounts shell name, which should be the first 8 letter of the domain name.
                          Thanks for your response, Justin. What I didn't explain is that I want to have SFTP-access (aka not SSL, but secure shell) but only allow SFTP and disabling the possibility to get commandline access. (Sorry 'bout that lad.)
                          DomainSwede.com

                          Twitter

                          Comment

                          Working...
                          X