Announcement

Collapse
No announcement yet.

How Can I Secure My Website Fully

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • How Can I Secure My Website Fully

    Hey There,

    I have a website "eladiestailor .com" that I purchased recently. I installed SSL certificate but when I am opening internal page without "HTTPS" then it is not redirecting correctly which means showing two different pages one with "http" and other one with "https". Please lead me and resolve my problem.

    Here is the example!
    https:// eladiestailor com/2019/09/25/hello-world/
    http ://eladiestailor com/2019/09/25/hello-world/
    Thanks & Regards
    Editor at Best UK Web Hosting

  • #2
    Hi Morinmote1

    You need to add the following code to your vhost file for domain or into .htaccess file

    Many thanks

    John

    RewriteEngine On
    RewriteCond %{SERVER_PORT} 80
    RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
    Last edited by d2d4j; 10-01-2019, 07:24 AM.

    Comment


    • #3
      I already put that code but still have same error. Do i need to reinstall wordpress and SSL?
      Thanks & Regards
      Editor at Best UK Web Hosting

      Comment


      • #4
        Hi morinmote1

        Did you restart apache once you added it to the vhost file for that siteworx account

        As itís a wordpress site, you can set https from within Wordpress admin, settings I think

        If using .htaccess, you may need to change slightly the code I posted so htaccess redirects

        All I can let you know, the code works lovely on all our servers

        If changing vhost_siteworx.url.conf file - where are you inserting the code

        Many thanks

        John

        Comment


        • #5
          Hi

          Sorry I just checked your url link for http and it redirected to https...

          Many thanks

          John

          Comment

          Working...
          X