No announcement yet.

Several issues with Prestashop

  • Filter
  • Time
  • Show
Clear All
new posts

  • Several issues with Prestashop

    Hi all,
    I hope someone can explain what I am doing wrong or where else the problem might exist but Prestashop on Siteworx drives me mad.
    Coming from cPanel with EA4-PHP-FMP and now on Siteworx with PHP-FPM nothing but messages about missing configuration settings.
    First I had the mod_rewrite issue in the Shop Parameters, Traffic & SEO, Set up URLs section, which I could solve with creating a file with a setting which I found on the Prestashop forum.

    The very latest issue I have now is this one in Advanced Parameters, Webservice.
    Please activate the 'mod_auth_basic' Apache module to allow authentication of PrestaShop's webservice.

    Checking on the server shows same as in the Nodeworx under Web Server [green and enabled]

    httpd -M | grep auth
    auth_basic_module (shared)
    auth_digest_module (shared)
    authn_anon_module (shared)
    authn_core_module (shared)
    authn_dbd_module (shared)
    authn_dbm_module (shared)
    authn_file_module (shared)
    authn_socache_module (shared)
    authz_core_module (shared)
    authz_dbd_module (shared)
    authz_dbm_module (shared)
    authz_groupfile_module (shared)
    authz_host_module (shared)
    authz_owner_module (shared)
    authz_user_module (shared)

    httpd -M | grep rewrite
    rewrite_module (shared)

    In the back-end, Advanced Parameters, I have enabled for this Webservice the setting: Enable CGI mode for PHP to YES.

    Why o Why?

    Kind regards,

  • #2
    Hi Nico

    I hope you don't mind, but I am posting this to help all users

    It would appear the issue is related to PS and not IW/apache/php - see link

    The fix is in prestashop (this is not currenlty reflected in softaculous)

    Prestashop and 1.6 versions do not have this issue

    I hope that helps a little

    Many thanks



    • #3
      Hi John,
      Thanks ever so much for the confirmation.
      Kind regards,