Announcement

Collapse
No announcement yet.

On Vacation replies with full headers

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • On Vacation replies with full headers

    When you enable the On Vacation option in your mail box and someone emails you, then they receive a reply with the full message headers.
    Very confusing for the receiving party and way to much information given away. How to turn that off?

    Example of a reply:

    X-Spam-Checker-Version: SpamAssassin 3.4.2 (2018-09-13) on xxxx.xxx.xxx
    X-Spam-Level:
    X-Spam-Status: No, score=-98.8 required=7.0 tests=DKIM_SIGNED,DKIM_VALID,
    DKIM_VALID_AU,RDNS_NONE,SPF_HELO_NONE,USER_IN_WHIT ELIST autolearn=no
    autolearn_force=no version=3.4.2
    Received: (qmail 11203 invoked by uid 108); 25 Oct 2019 10:00:14 +0100
    Received: by simscan 1.4.0 ppid: 11153, pid: 11159, t: 0.6589s
    scanners: spam: 3.4.2
    Received: from unknown (HELO xxxx.xxxx.com) (xxxxxx)
    by xxxx.xxxx.xxx with ESMTPS; 25 Oct 2019 10:00:14 +0100
    Received-SPF: pass (xxx.xx.xxx: SPF record at xxx.com designates xxxxx as permitted sender)
    Received: from [xxxx] (xxxxx [xxxxx])
    by xxxxx (Postfix) with ESMTPSA id 9852B1A071F
    for <xxxx>; Fri, 25 Oct 2019 10:00:13 +0100 (BST)
    DKIM-Filter: OpenDKIM Filter v2.11.0 xxxxx 9852B1A071F
    DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=xxxxx;
    s=default; t=1571994013;
    bh=UyvbwyziIy3ajrKngY3IOv6VViRFzAcOy/WyRWREYCM=;
    h=Reply-To:To:From:Subject:Date:From;
    b=kX0OpMeu7g9tRsyKGaVLmxv8hNOvcUFdE8TrE4+vOhk1Csvj KAkSKrCMYmyIgLe7/
    aJgFoDd5JupwXypkgoYPTdiP7igCrHoUO/ZqOit/Jxk9699v/F99QavOK5KUiNvluy
    ef/2KweucgMRVtpMAKhNnAYF7Bbib+pRtiiz1
    mhqYFZh1uEKHD9wbm3eACkU5z2D5NgVBjcueXCZ7IvCFjQi0UP gto2qK U
    +WrTn2er6So8uMZcVhWhH5oTi7Ij7FsRL7tNFEWDT7joIGcSyH 38QQyFGar1ufgozJ
    RxJIjJuCu2IPg==
    Reply-To: xxxx@xxxx
    To: xxxx@xxxxx
    From: "xxxx" <xxx@xxx>
    Subject: vacation?
    Openpgp: preference=signencrypt
    Autocrypt: addr=xxxo@xxx; prefer-encrypt=mutual; keydata=
    mQGiBFdgDsYRBADODe1VdxDvZ+dgU/wxn67tw6U5JQ+8Ow+8EimV1QkweDY8u2GopAy/Yd/e
    hDNXVev7OX1STG7duZYgft0jXr1r+o8d5GtuDoO6dQ5G8O2kRG 9NG6Mz1CXkOhoV2NjMj5VI
    mKaBAoXNIcdiRd8JVLTK6Lm3Loswh++3M08caMXijwCgqwDVYW VsB/F+zj15e6syzsclAXsD
    /2z5XoSOEich4YwNESVbUz9m8KkZxpWd3hOqQtOWRDfoWVlNutR oPRQdvR91KzjKebKbgQBx
    19APeXeTRkqI0sB6qdpnqcSNJCvQdK1l7hvxnYiIBTb/8Mjo7o4lsoiQ1AGU994EAZYLMcwz
    fIEwhsI7FhHplEDyu8sVpk+0cQfUA/9VVWGa4YVvuJ5g/j3yE573gAviznbUjGcaXMop+v6g
    8DRblAc8ebO3k8N39nGX/k7PPrLr317Z/8JxQKve5/LVcn1mud/zsS7wQblD3yQvSo10LDRV
    bRznrSzJaKm7bLIslqsCx4Ve0xJpMa
    aCMAs86uyR1HjUOZoBEy7+J0OKyAgNjd6ha+3GlGxwzPLaZ3JP SBnZnZr4RTC6H9ChcdQpl8
    Oweihxp+14lXakXd48MYb9XxckP14fpe3X4ob1A+HwCxUVw3Cx sboohJBBgRAgAJBQJXYA7G
    AhsMAAoJEOeV/8d2dtPJC8AAnR5o9cHciZvg75SFE+06nHIvQ/TTAJ95zBE605xIecjFStDF
    GkVe3q+d/g==
    Organization: xxx.
    Message-ID: <53867793-697a-faf2-76cc-08873b6d4887@xxxx.com>
    Disposition-Notification-To: "xxxx." <xxxx>
    Date: Fri, 25 Oct 2019 10:00:13 +0100
    User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:60.0) Gecko/20100101
    Thunderbird/60.9.0
    MIME-Version: 1.0
    Content-Type: text/plain; charset=windows-1252
    Content-Transfer-Encoding: 7bit
    Last edited by Nico; 10-26-2019, 03:38 AM.

  • #2
    Hi nico

    There should be a simply switch which needs changing from 1 to 0 within .qmail but I cannot find the file which holds this switch

    The 0 tells it not to include the message

    Many thanks

    John

    Comment


    • #3
      Hello--

      I need a bit more information--do you mean that the header is what is being sent and seen instead of the vacation message, or do you mean that, when you click "view source", you can see the full headers, and you do not want people to be able to see that information?

      Comment


      • #4
        Hi Jenna

        Many thanks and hope your well

        The responder responds with the responder message and just below it, is the full header details of the email it is responding too

        Eg

        Response message set

        Holiday

        Responder replies with

        Holiday

        All header details of the email received it is responding too

        Many thanks

        John

        Comment


        • #5
          Hi, d2d4j IWorx-Jenna

          Plus we get emails building up in the mailbox but I am no 100% sure as we tried it so many times.
          You can see at the beginning of my post the full header, I took most important privacy details away.
          Kind regards,
          Nico

          Comment


          • #6
            Nico

            Having both the message and the headers in the bounce back is standard behavior, though if you'd like to submit a ticket to the helpdesk with access information to your server, I can patch it so that info does not show up. I can also take a look at your mail-stuck-in-queue issue (if I am correct that that is what you mean by "Plus we get emails building up in the mailbox but I am no 100% sure as we tried it so many times.". Though I will need more info as to what you mean by "but I am no 100% sure as we tried it so many times.").

            One thing of note, though, is that, while I'm able to remove the headers, both the plain text and html versions of the original message do still show in the response. I've been testing for a few hours with trying to remove the html bit, but it may not be possible. So the response would look like the following:
            Re: Vacation test 2

            From receive@iwtest.comAdd contact Date Today 11:23
            Message Body

            I'm on vacation!

            -------- Original Message --------

            Date: Mon, 28 Oct 2019 11:23:37 -0400


            test message

            <html><head><meta http-equiv=3D"Content-Type" content=3D"text/html; charset=
            =3DUTF-8" /></head><body style=3D'font-size: 10pt; font-family: Verdana,Gen=
            eva,sans-serif'>
            <p>test message</p>

            </body></html>

            Comment


            • #7
              Hi IWorx-Jenna
              I have been trying to find out how it works and found some more parameters information, perhaps it is any use for you?

              Usage: | /usr/local/bin/autorespond time num message dir [ flag arsender ]

              time - time in seconds to consider consecutive
              num - maximum number of messages to respond to within time seconds
              message - the message file
              dir - directory to store list of e-mail addresses
              optional parameters:
              flag - handling of original message:
              0 - append nothing
              1 - append quoted original message without attachments
              arsender - from adress in generated message
              * = None
              + = blank from envelope !
              $ = To: address will be used
              headerkeep
              headerstrip

              headerkeep \fR(string)
              If this option is given, only the headers listed in the value are copied
              from the message into the response. Separate header names with a colon.
              If neither this nor headerstrip are used, all headers are copied.

              headerstrip \fR(string)
              If this option is given and headerkeep is not, the headers listed in the value are omitted when copying from
              the message into the response. Separate header names with a colon.
              Header names are treated as patterns, and so may contain
              .I *
              to match any string. For example, the pattern
              .I x-*
              will match the headers
              .I X-DomainKeys:
              and
              .IR X-SpamLevel: .

              Autorespond is located: /usr/bin/qmail-autoresponder
              User message is located in /chroot/home/user/var/domain/mail/mailbox/vacation
              /usr/local/interworx/lib/autorespond/vacation.sh
              /usr/local/interworx/lib/autorespond/autorespond.sh

              Hope that helps.

              The email is building up in the persons emailbox,, who has enabled the vacation message, from communication with person, it seems that quite a few where coming but we where testing, so it might be 'noise' of trying...

              Kind regards,
              Nico

              Comment


              • #8
                Hi IWorx-Jenna
                Ticket submitted, PJO-266266
                Kind regards,
                Nico

                Comment


                • #9
                  Hi d2d4j , IWorx-Jenna

                  All sorted now, Interworx support Jenna fixed it by adding an extra option on the row in the vacation script, -O headerkeep="Date"
                  It will still give some raw text [garbage] in the reply if the email contains an attachment with images or other html coding,
                  but by using the headerstrip option all is stripped out. [see my previous findings]

                  $AUTORESPOND -t 50000 -n 40 -O numlines=0 -O copymsg -O headerstrip="*" $USERDIR/vacation $USERDIR

                  Thank you both, Jenna and John for all the help, much appreciated.
                  Kind regards,
                  Nico
                  Last edited by Nico; 11-01-2019, 04:03 PM.

                  Comment

                  Working...
                  X