Announcement

Collapse
No announcement yet.

Unwanted Authorization Request

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unwanted Authorization Request

    Hello guys,

    I currently working on a webshop project ,which I inherited from previous devs.
    This site was working fine, just need magento upgrade and some additional features. It was decided to also upgrade kernel version. I also updated some of the packages that were available.

    Now when I go the site, I get authorization request.
    Click image for larger version

Name:	auth.png
Views:	1
Size:	6.3 KB
ID:	40998

    I'm not really sure what happened here, and whether it was caused by upgrades.

    Any help would be appreciated.

  • #2
    Hi bmbr

    Welcome to Iw forums

    I would check your htaccess file(s) for protected folder(s), as your picture shows area is protected, and you need to login to access the protected folder

    This is not as a result of Iw upgrade and upgrading megenta by .sh, again is not a cause of this I don't think

    If all else fails, do you have a backup of the website you could restore

    I hope that helps a little but there are a lot of extremely experienced users on the forum whom may different advice

    Many thanks

    John

    Comment


    • #3
      Hi, and thanks for the quick reply.

      Where should I look?
      The directory where magento is installed is /home/[siteworx_user_name]/[domain_name]/html, and it has it's .htaccess files.
      Even when removing/renaming html directory I still get auth request, which makes me thing it has nothing to do with htaccess files inside.
      I do have full backup, but sadly, but it is not recognized through siteworx/nodeworx.
      When I was backing up it could save it in defualt location, (/home/[siteworx_user_name]/[domain_name]/iworx_backup), I was getting permission error.
      But if I put another location (/home/[siteworx_user_name]/[domain_name]/backup_date_something) it works.
      I tried restoring, but as far as I know siteworx only restores partial backups, and I get error when trying to restore through nodeworx when I point to that file.
      File looks like this "[domain_name]-full-Nov.24.2016-15.02.04.tgz"

      Comment


      • #4
        Hi bmbr

        Many thanks

        For a test, I would rename htaccess on root hosting (/HTML) and upload a simple test php page, to see if this can referenced in a browser without the login notification

        If it can, it would point to a htaccess setting somewhere

        What distro, php, ioncube and Iw-CP are you using

        Many thanks

        John

        Comment


        • #5
          I don't have /html dir. There is html dir in /var/www/html, and there is iworx-test page.
          Interestingly enough when go through https://[domain_name] I land on that page.

          Linux CentOS-67-64-minimal 2.6.32-573.12.1.el6.x86_64
          PHP Version 5.6.28
          Iw-CP v5.1.36

          I'm not sure for ioncube.

          (I did a php update, might that caused this?)

          Comment


          • #6
            Hi bmbr

            Many thanks and something has drastically been changed

            You should have a HTML as follows

            /home/unixname/siteworxdomaim/html I think from memory

            The HTML folder you refer to, is default and not used

            Changjng php would not make this change I do not think

            What does you vhost file look like /etc/httpd/ I think there stored in, but apologies, I am doing this from memory as I am not in the office

            Do you have any other websites on server and are they working ok

            I think this maybe wrong in the host logic of that 1 site

            If needed quickly, I would open a support ticket with your license provider and include this thread

            Many thanks

            John

            Comment


            • #7
              What I meant I don't have a html dir in root of the machine.
              Yes, I have something like this "/home/unixname/siteworxdomaim/html"
              there is also a public_html in /home/unixname that points to "/home/unixname/siteworxdomaim/html"

              Sadly we have only one website with one ip :/

              I tried changing port for webserver to 8080, and back to 80, and restarting server.
              Somehow this solved Authorization Request. Now when go to domain-name, I don't have Authorization Request. But it doesn't show index page of /home/unixname/siteworxdomaim/html. Instead it show default Interworx Test Page (located in /var/www/html).

              As for support, since I'm doing this for a client, is support free, since I don't want to incur charges to client without his permission.

              Comment


              • #8
                Hi Bmbr
                Many thanks
                Yes, support would most likely cost and I think, but sorry if I am wrong, that you maybe using the free 1 domain IW-CP, as you stated only 1 domain on 1 IP.
                The logic is same though, and if your hitting the default apache location, I would check your DNS and IP address, as a reference to an unknown would match as IP address, and serve from apache default location.
                also, have you setup https in the siteworx account, because if this is not setup or changed in vhost file, then any reference to https//domain would again pass through to apache default /html
                Lastly, and sorry if I am wrong, just thinking aloud, are you sure it is going to default apache folder, and not the siteworx html folder... is the default IW index.php/html file still present on the siteworx/html folder.
                I hope that helps a little, but sorry if I am wrong, its hard not knowing your server
                Many thanks
                John

                Comment

                Working...
                X