Announcement

Collapse
No announcement yet.

Softaculous sometimes has problems cloning sites + Solution

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Softaculous sometimes has problems cloning sites + Solution

    Hi all,

    just wanted to let you know about an issue I have cleared with the Softcaulous support in case somebody else encounters this:

    Here's our ticket:
    We have several servers runnning Softaculous and encounter a problem with wordpress cloning since a while. The problem occurs during the checking phase, the cloning process says "Checking the submitted data" and then gets stuck at exactly 95%, on all servers I have tested. We are running Soctaculous on Centos 6.9 or 7.3 machines with the latest Interworx panel.
    and here's what they found:
    We were able to debug the issue.

    Softaculous executes on /home/interworx/bin/php binary of Interworx panel. But this binary does not have user access. When commands such as clone, auto backup, auto upgrade, etc are executed as user, Softaculous step down as user and executes these commands.

    Due to this, user does not have access to this binary in clone, hence we make use of the default php binary of the server.

    Now on your server, both the binaries have a different PHP version and both require different ionCube Loaders to decode the files. This is causing the issue as Softaculous files are encoded according to the version of /home/interworx/bin/php binary and in clone, executed with a different binary having a different version which requires different version of ionCube Loader.

    We'll make a fix for this in which we'll ask users about the PHP binary to be used. But this will take some time. Till then, please make both the PHP binaries on same PHP version and then check.
    So, either keep your php on 5.6.30 (which is the current php-iworx version) or wait for a softaculous update if you also have this issue.

    Cheers,
    Michael

  • #2
    Hi Michael

    Excellent post, kudos to you

    Interestingly, the RC update which caused a few issues with smarty, I believe also updated ioncube loaders, so I'm thinking softaculous and IW may have resolved this.

    Sorry if I'm wrong though in advance

    Many thanks

    John

    Comment


    • #3
      Hi all,

      since I ran into the same issue again, I asked Softaculous for the status of the fix and here is their answer:

      Extremely sorry for the delayed reply.

      Yes. We have implemented the filter in which you can pass the path of the PHP binary with which you want to Clone your sites.

      Please provide the path in soft_php_bin filter in filter.txt file which you can find in the following location on your server:
      /usr/local/softaculous/enduser/hooks/filter.txt

      Please uncomment the following code block in the file and add your PHP binary in it:
      //Use this filter to pass the path to PHP binary which should be used to perform operations like Clone, Remote Import, etc.
      insert_filter('soft_php_bin', 'my_soft_php_bin', 1, 1);

      // @param string $phpbin Path of php binary
      function my_soft_php_bin($phpbin){

      // Note : The PHP binary should be a CLI PHP binary
      $phpbin = '/PATH/TO/PHPBIN'; //Define your php binary here

      return $phpbin;
      }

      Once done, rename the filter.txt file to filter.php and then try cloning your sites.
      Hope this helps others

      Comment

      Working...
      X