64 Bit Linux and Iworx

I already asked the new IworxTim about this and he said Iworx does support 64 bit and just wanted to know if anyone was using this already and if they have run into any problems.

I’m most likely going to upgrade to a 64 bit athlon server and get CentOS 64 bit installed and wanted to see what i was get’n into. I assume most of the bugs have been worked out since 64 bit isn’t really that new anymore.

Any info would be much appreciated!


NEXCESS.NET has the 64 bit version on about 8 boxes (all CentOS 4, which is the only 64 bit op sys fully supported right now) and it runs well Justin.


I’m using CentOS 4.2 x86_64. I’ve found a few bugs here and there (for which I’ve shared solutions when I find them), but for the most part it’s clean. I’m happy to help where I can.


Do you notice any improved performance vs the 32 bit servers?
Are all programs used on a standard Iworx box native 64 bit programs (ie. apache, qmail, etc.)?

Thanks for the info. I may be switching to your new reseller partner Steadfast and they have good prices on 64 servers. My celeron isn’t going to make it much longer :wink:

This is going to be for a production server, what type of bugs have you found? Little problems or problems that would prevent the server from serve’n webpages?

All bins are native 64 bit.

The main things that I found (you can read about them here) had to do with CentOS installing i386 binaries alongside 64-bit libraries. There are also periodic issues where you’ll need to create symlinks in 32-bit directories pointing to the 64-bit binaries.

No show-stoppers. Just some minor annoyances.

I’m also running 64 bits on a dual Xeon with 64 bits capacity and no real problems. Maybe a couple of itches, but nothing serious. :slight_smile:

Running an AMD Opteron64 (CentOS 4.2) and no problems, just had to change “extension_dir” on php.ini:

extension_dir = “/usr/lib64/php4”
instead of
extension_dir = “/usr/lib/php4”

The errors that php thowed were:

php -v

PHP Warning: Unknown(): Unable to load dynamic library ‘/usr/lib/php4/ldap.so’ - /usr/lib/php4/ldap.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning: Unknown(): Unable to load dynamic library ‘/usr/lib/php4/mysql.so’ - /usr/lib/php4/mysql.so: cannot open shared object file: No such file or directory in Unknown on line 0

The above php.ini modification fixed it.




Thanks for taking the time to give me the download on the 64 linux.

I decided I am just going to pay for 2 servers for a couple months and make sure everything is running well before I point the DNS to the new server. But I now am confident that it shouldn’t be too much of a headache and look foward to having a nice fast server!

Thanks again


the extention youchanged, I have it like that on my box, (2x xeon 64 with Centos 4.2 64)
it still gives me those errors ?

Any sugg. ?


If after restarting httpd with ‘service httpd restart’ you’re still getting those errors, perhaps is not the correct path.


locate ldap.so

To see where in your server is the file that PHP is complaining about and then changing the php.ini accordingly.

If locate says:
warning: locate: could not open database: /var/lib/slocate/slocate.db: No such file or directory

Then you need to do a:


And then retry the ‘locate’ command.


that’s exactly what happened, busy doing the update, though my php file is in the “lib64”


Can you tell me what this “foo_module” is about and why when I enable it “httpd” cannot restart ?

Hi Arthur-

The foo module is just an example in the httpd.conf file of how to add a module to Apache. It is not meant to be enabled.



If I purchase a dedicated ip for a hosting account, how do I enter on my server, now obviously my server has static ip’s, but how do I go about adding the dedicated ip and making it work on a particular site ?

You can do this in the main Nodeworx screen, by going to Server Setup and IP Management. From there, you can add the IP, which will add it to the eth0 config for you, and you can set it as a dedicated ip.

That’s it in a nutshell.

That’s often the best way to do something major like that; when you are making such a big switch – that way you won’t feel rushed to move the accounts over eiter so the DC can kill the other box. Sago has always been very accomodating to me when I switched (personal) boxes, but something major like a distro switch or from Intel to 64bit is a little more daunting (or can be).

Dang that was a long response . . . short answer I think that’s a good idea.

Well this is also going to be a switch from Sago Intel Cele RH9 32bit to a new provider (SteadFast as it stands right now) on a AMD Athlon 64 Bit with CentOS-x86-64. Its definately going to be quite a change.

I haven’t yet decided 100%, I may see what Sago can offer me, but their prices have really gone up a lot in the last 6 months and SteadFast seems to be a pretty good young, growing company. I mean I can get 100 Mbit connections with no extra charge, an AMD (which I prefer), 64 bit, etc. etc. :smiley: And Tim I did check out that website forum link you told me about and they didn’t have a lot on SteadFast but what they did have was honest looking and for the most part very positive (thanks for the link).

Short answer are no fun anyway
I need something to read to pass the time :smiley:

No problem, glad you found it usefull. Webhostingtalk is very well recongized in this industry and was a sponsor of HostingCon last year, iirc.

You’ll be seeing me haunting those forums more these days, keeping track of conversations about hosting control panels in general and InterWorx in particular :slight_smile:

Short answer are no fun anyway
I need something to read to pass the time :smiley:

Haha, noted :slight_smile:

Keep us aprised of your decision and experience. Your fellow clients will be interested in what happens and the InterWorx staff is also interested in client experiences with our reseller/partners.