Backup issues

When I run;
/home/interworx/bin/backup.pex
–domains=all --all --ftp
–transfer-ini=/root/transfer.ini
--email=email@email.com

as a cron, via the web control panel (interworx) it runs multiple times and crashes my server, why is that?

/home/interworx/bin/backup.pex
–domains=all
–ftp
–quiet
–transfer-ini=/backup/transfer.ini

The above works for us. I would suggest, unless there’s something I’m missing, removing the --all as the --domains=all is doing what you need it to do.

I have run it over the command line interface and it works fine… that is the mystery to me…

Can we see the cronjob? Perhaps you have the cronjob set to run too often.

Socheat

I set it through the cron part of Nodeworx and set to run at 11 pm (23) every day.

I copy/pasted the same syntax as I use through the commandline interface (SSH) and while it worked via SSH, it was creating multiple (failed) backups
through the cron job.

Perhaps there was an error with linebreak using the web-interface at Nodeworx and I should edit the cron through the commandline interface instead?!

Could be, but without seeing the actual cronjob that was stored in the crontab file, it would be hard to say.

Socheat

I’ll try to add it “manually” and get back to you whether there was any difference in the output or not.