Basic Backup Script

I’m trying to just setup a basic backup script that will backup domains to an ftp site. I’ve followed the How to create a siteworx account backup here:

And believe that my transfer.ini is correct

[siteworx.backup_transfer_data]
username=“user”
password=“password”
hostname=“255.255.255.255”
remotefile="/backup/"

But this is what it spits out:

begin transferring (ftp) backup file: domain.tld-full-Apr.13.2007-12.18.34.tgz
error transferring (ftp) backup file

##LG_BACKUP_XFER_INI_USERNAME_INVALID## :
##LG_BACKUP_XFER_INI_REMOTEPATH_INVALID## :
##LG_BACKUP_XFER_INI_HOSTNAME_INVALID## :
##LG_BACKUP_XFER_INI_PASSWORD_INVALID##
##LG_BACKUP_XFER_INI_PORT_INVALID## :
##LG_BACKUP_XFER_INI_PASV_INVALID## :

Is there something obvious that i’m doing wrong? So obvious I can’t see it?

Thanks

No, not so obvious. :slight_smile: The .backup.transfer.ini file format changed slightly in v.3.0 and we haven’t updated the documentation yet. Try this instead:


[ftp]
username="user"
password="password"
hostname="255.255.255.255"
remotepath="/backup/"


Now it’s throwing this error:

##LG_BACKUP_XFER_INI_REMOTEPATH_INVALID## :
##LG_BACKUP_XFER_INI_PORT_INVALID## :
##LG_BACKUP_XFER_INI_PASV_INVALID## :

So i’ve changed the remotepath to

~/backup/
/backup/
/backup
/

And none of the above work.

I can’t find any informationa bout PORT_INVALID or PASV_INVALID

other settings in the .ini I need to be setting?

Hi thegoat.

This is a confirmed bug in 3.0 RC2. It will be resolved in the next RC update, due out shortly.

You should be able to work around this issue by adding the following two lines to the .backup.transfer.ini file:

port=“21”
pasv=“off”

Also, double check that “remotefile” in that file has been changed to “remotepath”.

Paul