Blank Mailbox

I am having a problem with one of my siteworx accounts. Everything seems to work correctly except when I try to load the ‘mailboxes’ section. When I click on the link for the mailboxes it brings up a blank page. All my other siteworx mailboxes are working fine too. What do I need to do to fix this problem??

If you could open a support ticket with your root login information and NodeWorx login information we’ll check out the problem for you. Also, please include the name of the SiteWorx account that’s causing the problems.


I rebooted the server for the first time in almost a year and it fixed the problem with the siteworx ‘mailboxes’ page that wasn’t working. :smiley:

I do have a new problem though that is more of a configuration problem. After rebooting the box I can only authenticate my email via a secure connection to the POP3and SMTP servers. I have a few customers with several mailboxes and I would like to change the mail server back so the mail clients don’t need a secure connection. It would be a lot easier than having all my customers re-configure all their client machines with the new settings. Question is… How do I change Nodeworx to not require a secure connection for email?

I submitted a support ticket… Unfortunately my login isn’t working properly with the ticketing system so I can’t login and check the status of my open ticket. Could someone throw me a bone here?

Hi Lost,

I just responded to your support ticket. I’ll see if I can find or reset your helpdesk login info and email it to the address you provided in the ticket.


In hindsight, emailing it to you probably wasn’t the smartest thing to do, considering your issue is with receiving email. :slight_smile:

Here was my ticket response:

I created a test email account:, and configured my mail client to use POP. When I tried to check my mail, I got the following message:

Error sending password: Server Response: vmysql: error creating table relay: Table relay already exists

The fix for this is to repair the iworx_vpopmail.relay table. However, I’m not able to SSH in to your box. I’ve tried disabling the firewall, and with firewall on or off, I still get a “Connection Refused” error. Is SSH running, or do you have SSH running on another port?

If you’d like to repair the table yourself, here are the steps to follow (as the root user)

1.) First run: grep dsn ~iworx/iworx.ini | grep vpopmail

This will return:

2.) Then run: /home/interworx/bin/mysql/mysqlcheck -r -u iworx -p iworx_vpopmail relay
and supply the password you found in step 1.

If you’re not comfortable with running these commands, let me know when SSH is working, and I can fix it for you.


Thanks Socheat,

I did receive your response to my support ticket through a secure pop3 connection. Your solution did the trick and things are working normal again. Thanks for your help and quick reply. You guys are the best!

I had this same problem a while back and Socheat fixed it right up for me :smiley: