[Bug] Importing creating Skeleton


Last night a reseller did an import of 4 new Siteworx accounts from Cpanel Server Backups. 2 out of the 4 went smoothly and without a hitch (as per normal) however two managed to not only import the account, but also to import the skeleton files of the idnex.html page and the necessary interworx logos.

Any ideas on this, or is it worth re-importing to try and recreate, or is it a known bug?


It’s not really a bug. Whenever a SiteWorx account is created, those skeleton files are added. During an import process, a new SiteWorx account is created and then the webdata from the backup is simply moved over.


Thanks Socheat - it jsut appears that on these two accounts it caused a problem with having the index.html page there.

I am just testing another import and will see how we get on. With one of the accounts mentioned in my first post that didn’t fully work, I even had to set DirectoryIndex in a htaccess file else I got a forbidden error.

I shall do some more digging… :slight_smile:

What was the name of the index file? You should have the most common ones already set in the conf files found in /etc/httpd/conf and /etc/httpd/conf.d.


It was just index.htm and the skeleton file index.html was also in the directory. I shall have a look now and check the overall Apache settings…

(Just done another import and it when fine)

It appears that the /etc/http/conf/httpd.conf file somehow only had:
DirectoryIndex index.html index.html.var

whish is strange as index.php was being used. I have corrected this in the above file and restarted Apache. I will keep an eye on things and report back if I notice anything else.

Thanks Socheat.

Note that /etc/httpd/conf.d/php.conf adds the additional option:

“DirectoryIndex index.php”

Did you check to see if it was listed there?

I’ve found that it looks for thee other index files .pho .htm .shtm etc as long as index.html does not exist but since it’s the default and those template files are always created you either need to rename or delete/overwrite the template file.

I’ve always assumed that index.html.var was responsible for it recognizing the others.

Short of editig the main configs another option is to create a .htaccess file with

DirectoryIndex index.htm index.php index.html index.shtm index.html.var

in it.