chroot SFTP

How do I get this working? I’ve changed the user’s shell to /chroot/usr/libexec/openssh/sftp-server and added that entry to the /etc/shells file and also edited the location of the sftp-server in /etc/ssh/sshd_config but I’m getting authentication failure message.


Well I’ve figured this out. For anyone interested here is what worked for me:

1.) In NodeWorx change the user’s shell to /usr/sbin/jk_chrootsh and also change their status to ENABLE.

2.) Add the following shell to /etc/shells file:


3.) If it’s not already there, copy the sftp-server to the chroot directory:

mkdir /chroot/usr/libexec/
cp -Rp /usr/libexec/openssh/ /chroot/usr/libexec/openssh/

4.) Changing the user’s shell in NodeWorx should add them to the /chroot/etc/passwd file. Go into that file and change their shell to:


That’s it! :slight_smile: