Cluster : qmail-send failure notice email problem

Hello,

We have a cluster. Tell 2 boxes :

All web requests are load balanced to the node1.
The cluster manager runs others services as smtp/pop/imap/…

One of our client send emails from a PHP scripts. As the web requests are done on the Node1 the mail is send from node1.mydomain.com

The problem is that we receive (the postmaster of this node) Huge numbers of failure notice emails and our client doesn’t.

for example email like this one

Hi. This is the qmail-send program at node1.mydomain.com.
I’m afraid I wasn’t able to deliver your message to the following addresses.
This is a permanent error; I’ve given up. Sorry it didn’t work out.

<xxxx@hotmail.fr>:
65.54.244.168 does not like recipient.
Remote host said: 550 Requested action not taken: mailbox unavailable
Giving up on 65.54.244.168.

— Below this line is a copy of the message.

Return-Path: <root@node1.mydomain.com>
Received: (qmail 24778 invoked by uid 80); 13 May 2007 17:50:04 -0000
Date: 13 May 2007 17:50:04 -0000
Message-ID: <20070513175004.24777.qmail@node1.mydomain.com>
To: xxxx@hotmail.fr
Subject: C0ntact vous a envoy? un message sur SSP
X-PHP-Script: www.clientdomain.net/message_action_envoi.php for 62.35.103.49
MIME-Version: 1.0
X-Sender: <www.ClientDSomain.net>
X-Mailer: PHP
X-auth-smtp-user: webmaster@ClientDomain.net
Reply-to: ClientDomain.net <webmaster@ClientDomain.net>
From: ClientDomain.net <webmaster@ClientDomain.net>
Content-Type: multipart/alternative; boundary="_845ce075cf1b10d374c2dd459c896865"

I do not understand why our postmaster (/var/qmail/alias/.qmail-postmaster) receives this mail ?

Why this mail is not sent to our client ?

This issue happens only for THIS client domain !

Pascal

It’s because the client php script www.clientdomain.net/message_action_envoi.php is not setting a “Return-Path” header when it is sending the message. Bounce messages are supposed to go to the “Return-Path” header, not the “From” header. Since the php script sets to Return-Path header, the mail system creates one from the server info, so it turns into root@node1.mydomain.com. The php script should be able to be tweaked to set the correct Return-Path header.

Paul

Thanks Paul, but the case is a little more strange…

I thought of this, but if I load balance the Ip of this domain on the clust manager then I don’t receive these mails. In fact before, this domain had his web service load balanced on the clust-manager and I never received these bounce messages and since it is load balanced on the node I received them. Exactly as the node was configured differently than the clust-manager. I say that, but saying ythat is crazy, as I know that the bounce is send by the send pgm on the node, which is the same than the clust-maanger (?)

Ok I’ll look this more in depth and see if this client migth twreak this pgm

Thanks for the answer

Pascal

Well

Add the return-path information in the PHP script works, but I have tested the same script without the return-path set directly on the cluster manager and in this case I didn’t receive the bounce message !

So on the cluster manager, it looks like the return-path is set differently by default ?

Pascal

I have procmail installed on the node, could I delete it ?