# Creation of SW account in 4.0 gives "Invalid hostname: \<ip\>" error

**URL:** <https://forums.interworx.com/t/creation-of-sw-account-in-4-0-gives-invalid-hostname-ip-error/12426>\
**Category:** Bugs\
**Tags:** bug, nodeworx, siteworx, hostname, invalid\
**Created:** [September 16, 2009, 1:56pm UTC](https://forums.interworx.com/t/creation-of-sw-account-in-4-0-gives-invalid-hostname-ip-error/12426 "2009-09-16T13:56:26Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Fr3d](https://forums.interworx.com/user_avatar/forums.interworx.com/fr3d/32/27_2.png) [@Fr3d](https://forums.interworx.com/u/Fr3d)\
**Post date:** [September 16, 2009, 1:56pm UTC](https://forums.interworx.com/t/creation-of-sw-account-in-4-0-gives-invalid-hostname-ip-error/12426/1 "2009-09-16T13:56:26Z")

</div>

I’m getting an error when trying to add a new SiteWorx account in NodeWorx.

A picture (or screenshot) is worth a thousand words:

As you can see, everything looks okay.

I also found that it creates the DNS zone despite this error, but only the domain.tld, mail.tld A records and the www.domain.tld CNAME.

Surely account creation should be like a database transaction - either it all succeeds, or any changes that did succeed before one bit failed are reversed?

Let me know if you’d like me to submit a ticket with login details if you want to look at the server.

---

<div class="post-metadata">

**Author:** ![Paul](https://forums.interworx.com/user_avatar/forums.interworx.com/paul/32/6_2.png) [@Paul](https://forums.interworx.com/u/Paul)\
**Post date:** [September 16, 2009, 4:49pm UTC](https://forums.interworx.com/t/creation-of-sw-account-in-4-0-gives-invalid-hostname-ip-error/12426/2 "2009-09-16T16:49:35Z")

</div>

Most likey the problem here is with the DNS Template zone configuration. I’d have to see it to see what the actual problem is though.

Paul

---

<div class="post-metadata">

**Author:** ![Fr3d](https://forums.interworx.com/user_avatar/forums.interworx.com/fr3d/32/27_2.png) [@Fr3d](https://forums.interworx.com/u/Fr3d)\
**Post date:** [September 16, 2009, 4:53pm UTC](https://forums.interworx.com/t/creation-of-sw-account-in-4-0-gives-invalid-hostname-ip-error/12426/3 "2009-09-16T16:53:20Z")

</div>

DNS was indeed the problem - the nameservers had IP addresses rather than hostnames in their fields.  
Thanks for pointing me in the right direction 🙂
