ERROR in the last PHP release


If your iworx box has been updated with the last php release, you may have some problems with your php script.
In particulary with all connections to your databases,

To resolve this pbm you have to change the /etc/php.ini file

login to your server with root

Edit the /etc/php.ini file with your favorite text editor

vi /etc/php.ini

Find this line

extension_dir = "./" 

Update this line

extension_dir = /usr/lib/php4

Save the file and quit the editor

clic Echap, then enter  :QW

Now restart http server

service httpd restart

Everything shoud be better now.

Be carreful, this action work for me, but it doesn’t mean that it will work for you (depending your server config). In most case it should be

About the Iworx php ini file :

Don’t know if we have to do the same thing with the iworx’s php.ini file
which is at

extension_dir = ./

(not exactly the same than /etc/php.ini, there is no " ")

For this one, wait for iworx confirmation

Hope this would help

Just to note, this isn’t a global problem, only some boxes were affected and we’re nailing down which as I type this.


hehe looks like I’m one of them. It appears to have caused some other problems as well (some of the subdomains – the ones inside existing sw accounts – are not working, while some – which are their own sw account – are) so I’ve put in a support ticket. I’m wondering if it’s done something to NodeWorx (but NodeWorx does seem to load fine) since it uses php.

Got me to, but considering i dont use php for anything other than phpMyAdmin, i never knew :S

err InterWorx also requires php. InterWorx worked for me though it may have been a specific bug,

phpMyAdmin and iworx itself use a self-contained php (the php-iworx package) which didn’t have a bug :). so this is why iworx and phpmyadmin still worked ok.


Thanks, and thanks for fixing my server again. I’m keeping my fingers crossed that all of the bugs are squashed and the demons exercised :wink: