Few problems...

Hello,

I have installed (& bought) full version of Interworx CP…

  1. I have eth0 and eth1 with 2 static IPs, in CP both are “Shared”… Question is why first user in CP is owner of my IP and that looks like he have dedicated IP?
    I can see that when I try to open http://MY-IP/

  2. I have problems with option “PHP Mode: PHP Scripts run as SiteWorx user”, when that option is ON, there is problems with suPHP…

Mismatch between target UID (500) and UID (509) of file …

UID 500 is first user in database, UID 509 is user where I run php scripts…

Is it possible to fix that? :confused:

  1. I have eth0 and eth1 with 2 static IPs, in CP both are “Shared”… Question is why first user in CP is owner of my IP and that looks like he have dedicated IP?
    I can see that when I try to open http://MY-IP/

That’s the way apache works. If you have more than one domain on a shared IP address and navigate to http://ip/, it will show the first virtualhost on that domain, specifically this will be the first domain that comes alphabetically. What would you prefer happen instead?

  1. I have problems with option “PHP Mode: PHP Scripts run as SiteWorx user”, when that option is ON, there is problems with suPHP…
    Quote:
    Mismatch between target UID (500) and UID (509) of file …
    UID 500 is first user in database, UID 509 is user where I run php scripts…
    Is it possible to fix that?

What URL are you accessing the site at when this problem happens?

Paul

  1. Ok mate :wink:

  2. I tried with http://IP/~username but now with domain works fine…

New…

  1. Is it OK to set php.ini “session.save_path=/tmp” because clients with Joomla installations get errors like no cookies, with /tmp works fine… Security risk?

Hello,

I have server.name.domain where i want to test pages before I transfer domain…
I use it like server.name.domain/~username but I have often “Mismatch between target UID”

Is it possible to fix that with option to run php scripts as user?

I was going to reply with a lengthy post about an alternative to this behaviour, but I had an idea while writing it, so rather than risk the idea getting lost, I posted it in the feature requests forum :smiley:

Hello again!

I have problem with HTML and UTF-8 encoding…

With .htaccess and “AddDefaultCharset UTF-8” it works for all other files (php, js) just not for HTML… I just see some crazy chars, but on old host (cpanel) worked fine, localy html works fine…

I’d need more information to be able to answer that question. If you open a support ticket with your server details, I could take a look to see if I can figure out what’s wrong.