firewall ports to access ms sql server


What ports should be open at the iworx firewall to access a mssql server ?

I’ve tried to open ports 1433 and 1434 on iworx, but it still block connection, if i turn the firewall off, i get a successful access to the mssql server… so, it should be missing some port(s) to open (?)…

[SIZE=2] I also tried adding ports 1024-65535 (tcp/udp outgoing) to open (as [/SIZE][SIZE=2];EN-US;Q269882 )… but with no luck

Can you please help configuring the firewall ? :wink:
Thank you in advance[/SIZE]



If I remenber well the default listen port for MS SQL is 1433, so you’ll have to open this port for ingoing access and open all port for outgoing. (egress set to 0 in the config file)

What version of apf do you use ?

Do you really see in the apf log it blocks incoming requests on port 1433



The APF version is 0.9.5 …

the egress section is configured by default (iworx 3.0.2) and it looks like:

Egress filtering [0 = Disabled / 1 = Enabled]


Common egress (outbound) TCP ports


Common egress (outbound) UDP ports

Something i should do here to permit all ports open foi outgoing? or can i limit the ports 1024 thru [SIZE=2]65535 ?

Thank you in advance



If egf=0 it means the firewall won’t filter the outgoing datas so you don’t have to open these ports for outgoing

What is the port list for IG_TCP_CPORTS ? do you have the 1433 port in this list ?

Did you perform a “service apf restart” ?

What is the ms sql config file ? did you set a special listening port


Common ingress (inbound) TCP ports

I also did a stop / start (using iworx gui)

and nothing at the /var/log/apf_log …

so it is strange

Do you have some apf logs that tell it blocks port 1433 ?

Any logs in mssql ?


Do you have some apf logs that tell it blocks port 1433 ?

No …

Any logs in mssql ?
No …

It’s really strange… because, if i turn apf off, i can make the connection (telnet 1433)… if turn it on with the settings descrived … no connection is made (it does not reach the mssql server).

I took a lot of reading over google searches and no result came to my mind :-S