FTP Being VERY Slow


We have had a few reports of the LIST command on FTP being extrememly slow on one of our Iworx boxes.

Has anybody else experienced slow connections with ProFTPD?


I don’t believe we’ve had any reports like that so far. Have your clients tried with PASV mode on and off? Have you asked them to do a traceroute to the box to see if it’s possibly network issues?


Hi Socheat,

After much to’ing & fro’ing - we have two Iworx servers on the same network/DC. The client can FTP in fine to one of the boxes but cant to the other (where his site is!). He is using FileZilla. He can connect to the web site etc, so all would appear to be fine in termsof connection, and he can ftp in all okay to the other server.

We also have a client on MacOSX who uses ‘Yummy’ and had very much the same issue. He ended up turning off Passive mode and that seemed to cure it, however it hasn’t worked for this other client.

We aren’t getting any other reports of the same problem, however when using FTP ourselves we do notice a slight ‘lag’. We have no network issues to/from the server.

I’m starting to be completely bewildered by this one, as it seems very strange.

So, does anyone have any experience of this? Has anyone else known of this?



yes… i’ve also a lot of complains about slow ftp … not with one file, but with several files

Have you find any solution for this???


PS: It’s not a network problem

OK, I though I was the only crazy person here, I have noticed this in the past using SmartFTP. I usually had trouble when uploading large uploads, not necessarily a large file just a lot of files, anything over 3 or 4 mb total.

I had the server timeout changed and that helped. What also helped was when SmartFTP came out with a newer version and all the problems I had went away. So I assumed it was a SmartFTP problem.

One thing I did was used Total Command to FTP with when I had these issues with SmartFTP.

just to update …

I had also the same issues using smartFTP … i did’n ask what customers are using, but i’ll check also with them.

I’ve also increased the timeout, but no improvments were detected


Another Update, not sure what is going on, I tired to FTP a file up to the server first using SmartFTP, the transfer failed, so I switched to Total Command, same thing transfer failed, then I tried FileManager in the SiteWorx CP and tried uploading, it said I didnt have permission and looked at permissions of the directory I was loading to and it was showing 755.

I then pinged the network and network was running fine.

I then tired Total Command and SmartFT again and SmartFTP wasn’t showing any thing with LIST -aL command.

I then tired connecting with Total Command, always reliable, and I logged on ok, but when I tried to list contents of a Directory, it would list and timed out.

Again I checked the network and pings fine (81ms up from 74ms on last ping, no lost packets)

I again tried FileManager in SiteWorx and this time my file uploaded. But HOLY COW, it shouldn’t be this hard.

Yet another update, it appears, although FileManager said my file uploaded it never loaded.

AS of NOW I can NOT FTP anything I cant even get a listing of any of my directories with ANY program and network shows to be just fine.

R-n-R, this sounds like a permissions or directory / file ownership problem. The Filemanager has nothing to do with FTP - so both are having a problem, there’s probably some overriding issue. Feel free to open a support ticket if you need a hand.


another update …

ftp … may be something wrong … i’ll test and re-test with diferent ftp clients and i’ll post the results

when i have problems with ftp, i grab my winscp and the file transfer is great, as it should be with ftp