InterWorx 2.0 Released!

We’re happy to announce the release of InterWorx-CP version 2.0!

This update will be applied automatically within 24 hours if your server has auto-updates enabled (the default). If you choose to perform the update manually we recommend logging into your server as root, and running the command:

yum update

If you have any problems with this update please open a Support Ticket.

Here is a list of the major new features.

* New and Improved Interface
Streamlined “smart menu” improves page load time and usability
Improved functionality throughout the system.

* Reseller Support
Allow other users to create SiteWorx accounts, limited by the number of accounts they can create, and bandwidth and storage used - opening the door to a whole new way to use InterWorx-CP.

* Complete IP Address Management
Adding IP’s to your server has never been easier.

* Enhanced Service Control
Easy configuration and monitoring of your server’s critical services, including the web, mail, ftp, mysql, and dns servers.

* Account importers for other control panels
Including: cpanel, directadmin, plesk, and ensim.

* SSH shell user control with optional jailed shell configuration
Monitor shell users and control their access efficiently.

* Auto-script installer ScriptWorx
Makes the website owner’s life much easier, allowing one-click install of many popular software packages, including: Coppermine, dotProject, eGroupWare, gallery, geeklog, osCommerce, phpAdsNew, phpBB, and phpNuke

Thanks again to all those that helped this release along - the beta testers, the folks that posted feature requests on these forums, and everyone that uses InterWorx-CP… without you this release would never have happened! We hope you like it.

Paul & the rest of the InterWorx crew.

I’d like to thank all the BETA testers as well :D, good work all.

Also, we have new flash tutorials up for SiteWorx (and soon for NodeWorx). Feel free to use them for your clients:

http://interworx.info/iworx-cp/support/tutorials/#siteworx_flash

Chris

Looking great so far. Just as a heads up, I manually upgraded and when I went into my Nodeworx for the first time it was still using the old theme and all the links and layout were screwed up. I remembered that the page was themes.php though and when i clicked “download” on cool freshness (it claimed it was already selected) it selected it. Perhaps I just had an old cached copy of the css or something though. I’ve also got “User Logo” in the upper left of the cool freshness theme instead of a picture. I assume I can change that by editing the template, but the default probably shouldn’t be that.

Also, on the scriptworx page the popup to choose enable/disable for individual scripts does not submit the form properly in Safari 2.0. The same behavior works on every other page I’ve tried and the code looks identical so I’ll let you guys figure that one out. :wink:

Finally, where is the configuration for “optional jailed shell configuration”? I’m looking in the shell configuration area and don’t see any options to enable the jailkit package that I know was installed. :wink:

Oh, and congratulations on reaching the big 2.0 as well. May every future update be as immense as this one (48MB primary iworx package, wow!).

I did a manual yum update – smooth.

A couple of heads-up items:

  1. I had to reboot before any of the system graphs would work. Not a biggie, or a problem, just wasn’t sure if you expect that or not.

  2. When viewing the mailqueue page, the menu items in the navbar change to ##LG_FooBlah## (I have a screenie if that helps).

Nice upgrade. Thx for all the continued work on an already great product.

JB

Hello,

Wheres the skel dir? Chris said he had it seperated so that we could customize.

update went smooth, however I had to rebrand everything.

Thanks.

/home/interworx/etc/skel

:slight_smile:

All I have to say about 2.0… Thats Hot! :smiley:

Anyway to have the history of visual graphs/stats back? Not that I really care, but its cool to have.

Thanks Greg,

What about the rest. I would like to customize /home/username/dir and /home/username/domain.com/

The reason is I offer Dedicated jvm/jsp and I place the container outside of the html dir.

Thanks!

/***** MENU SHIZZLE *****/

Man you guys are pros :wink:

Anyway, I hate you guys. Don’t you realize I have stuff to do and shouldn’t be playing around with these cool new features? I swear you guys try and destroy me at every turn :slight_smile:

After looking at the shell goodness, I’d like to see some process accounting control and reports.

Edit: I’d also like to see the menu expand to the current location as well. I’ll put some real request posts in eventually :slight_smile:

Wow this is cool.

PaulK:

Thanks for the feedback. The initial problem may indeed have been a cached CSS file or something similar.

We’ll have to check out Safari, thanks for letting us know about that problem.

We’ll have a tutorial regarding how upgraded boxes can use the Jailed Shell option by the end of the weekend. It involves some manual steps and moving of some things around.

JayBean:

You shouldn’t have needed to reboot - how long did you wait? It might have just needed a 5 minute cron job to run to update the new graphs for the first time.

If you could open a support ticket and provide that screen shot (and preferably your login so we can reproduce it) that’d be great. That’s not a known issue so we’ll have to check it out on your server.

Kipper3d:

I’ll let Chris answer this question since I’m not sure off the top of my head about this question.

Justec:

Nope, sorry, the graphs are all brand new since we rebuilt the graphing infrastructure (it was based on cacti in previous versions, and it’s custom now).

Paul

CMI:

The Menu should “remember” its last position between page loads - if it doesn’t the first time, it should the second. Let us know if this isn’t working at all for you so we can check it out.

Paul

I can get “System Services” and “Server” to stay open, but not anything else. I’m using Safari 2.0 :slight_smile: I’ll try and poke around later and get you some usable info.

Ah, ok. There may be other Safari issues as well, that’s one browser we didn’t test with.

Paul

ScriptWorx?

I enabled all the sample scripts and enabled “ScriptWorx global options” (what is this?), but the scripts are still not available on the individual SiteWorx accounts.

RWF,

You have to enable ScriptWorx for the SiteWorx account you want to give access to, via the “Edit” button in the SiteWorx account list. Once you’ve done that there should be a ScriptWorx menu item in SiteWorx.

Paul

At least im not the only one that made this mistake :rolleyes:

http://interworx.info/forums/showthread.php?t=573

Is there any quick way to view the accounts a reseller has created? They don’t appear to show up in the generic siteworx account list and there’s no button to go into the reseller’s nodeworx account with one click like there is for siteworx accounts. :slight_smile:

My two cents…

The upgrade appeared to go smoothly, but my custom theme ultimately screwed me over. The theme was based on Vanilla Ice from 1.9.x, and when I went to login to NodeWorx, my web browser complained that “login.php” could not be found. Sure enough, it wasn’t in the RPM package either. I looked around a bit for how to manually change themes (since the catch was I could not login to NodeWorx to change my theme). Eventually, I symlinked the “interworx” folder to the folder name my custom theme was using. That worked, but why does NodeWorx not need login.php, but SiteWorx still has it? :confused:

I guess I’ll stick to the InterWorx theme from now on, unless anyone can give me some pointers about how to use a custom theme and not die/loose UI improvements between releases. :frowning:

On the other hand, I-CP v2.0 looks very nice from what I have seen so far. My upgrade battle left me victorious, but also too tired to go on. I’ll check it out tomorrow. :slight_smile:

I’m pretty sure it worked for me on Firefox.

Paul K:

When you’re logged in as the “main” nodeworx user, and you go to the “SiteWorx Accounts” page, there should be a dropdown where you can select a reseller, and view their accounts. This dropdown won’t show up though until you have at least one reseller created. If it doesn’t show up for you let us know (and let us know what theme you’re using).

Paul