Invalid InterWorx-CP License

Just yesterday suddenly my CP gives an error about a non-valid license. I tried updating the license manualy already but system gives errors.

[root@vps ~]# service ntpd stop
ntpd: unrecognized service


[root@openvz1 cron]# ls
bandwidth.pex dns.php license.php rrd.php storage.php
bandwidth.php ip.pex monitor.pex spam.pex update.pex
clearpasswordreset.pex ip.php monitor.php spam.php update.php
clearpasswordreset.php iworx.pex mysql.pex stats.pex vpopmail.pex iworx.php mysql.php stats.php vpopmail.php
dns.pex license.pex rrd.pex storage.pex
[root@openvz1 cron]# license.pex
-bash: license.pex: command not found

Anyone any ideas what the problem could be?


When in the /home/interworx/cron directory, you’d need to run:

./license.pex --sync

See if that helps. If that doesn’t work, open a ticket, and we’ll check it out.

Thx for the reply, so I tried en in return I get the folowing error:


[SIZE=2][SIZE=2][root@openvz1 ~]# /home/interworx/cron/license.pex --sync[/SIZE]
[SIZE=2]/bin/date: cannot set date: Operation not permitted[/SIZE]
[SIZE=2]/bin/date: cannot set date: Operation not permitted[/SIZE]

[SIZE=2]Any ideas how it can be that root-user is nog permitted to reset the time?[/SIZE]


On a VPS setup, an individual VPS instance is not allowed to modify the time, even if you are the root user. The time needs to be set from the dom0 or the parent server.


Logged on to hardware console and have CP back already.

Thanks Socheat!