Is there an IWORX (un)supported PHP 5.2 to 5.3 Upgrade?

I used this “supported unsupported” YUM method to upgrade to 5.2

Wonder if there is any InterWorx YUM method for updating to 5.3?
I found this method using RPM installs from an outside source on the forums, but still not sure I want to go that route.

I’m on CentOS 5.7 currently running PHP 5.2.17.

Do a “yum info php53” - I can’t say whether it’s supported, but it’s available in the “updates” repo.

Yeah, nice catch.

Just checked and I see in the iworx-unsupported repo there is the PHP 5.2 RPM I used in my last upgrade and the PHP 5.3. Strange that there is two PHP 5.3s in here. One older than the PHP 5.2 I used and one about a month newer. Not even sure how two files can exist with the same name in the same folder?

Also, when I run yum update it doesn’t find any packages marked for update.

 php-5.2.17-rhe5x.iworx.js.suhosin.fpm.200.src.rpm 11-Jan-2011 17:25   11M  
 php53-5.3.3-rhe5x.iworx.js.200.src.rpm            28-Oct-2010 22:49   13M  
 php53-5.3.5-rhe5x.iworx.js.200.src.rpm            20-Feb-2011 17:20   13M  

One is 5.3.3 and one 5.3.5

FWIW, on a fully up to date centos 6.2 box, php version is 5.3.3.

Whoops! Guess I should have put my contacts in this AM.

Yeah, I don’t feel 100% comfortable in upgrading from 5.7 to 6.x. So when I do it I guy a new server at my host and move the sites over, so it’s more of a pain to do.

So that’s why I was looking for a smooth way to move to 5.3 on 5.7.

Ah, I guess it doesn’t show the upgrade because the package name is php53 instead of just php.

Anyone from InterWorx know if I do a yum install php53 will that work with the suphp setup and any other InterWorx defaults?

I’ve done installs like that on customer boxes and everything’s worked fine. Your milage, of course, might vary.

Thanks for the reply Robert. Did you have to yum remove any packages to prevent package collision between php and php53? I assume that php53 package will install the same files / locations as php, just with a new package name.

The only compensation I needed was to make sure that anything that was running on php53 specified that it was using php53 instead of php in any paths.

I should clarify. It’ll install to /usr/bin/php53/ instead of /usr/bin/php/, so you need to watch that.

Hackish, but wouldn’t a symlink fix that?

Everything I’ve read about the CentOS 5.6 php53 is that it installs over the normal PHP packages, but they made it a different package so it wouldn’t automatically upgrade.

This is a good article explaining the process

I noticed that the only missing package is php53-pear.

So maybe this iworx version is different?

I’m starting to think it’s just not worth the trouble and I should just rent a new server with CentOS 6.x on it and be done with it.

Generally it’s ok to upgrade things on your box. Just note there’s a few exceptions that will break things.

The packages that need to be the same are:

This line should be added to any custom .repo file in /etc/yum.repos.d:
exclude = clamav-* courier-imap* daemontools* djbdns* jailkit* perl-rrdtool* proftpd* qmail* rrdtool* simscan* spamassassin* suphp* vpopmail* webalizer*

These packages are required to be the right version for them to interact correctly with InterWorx.