Mail Certificate

Is there currently a way with Interworx to use an specific SSL certificate with a Siteworx account for mail the same way it’s done with the web if it has a dedicated IP address? Before, with sites that have a custom SSL certificate, when using a mail client the certificate for the Interworx box is the one picked up and not the one for the domain entered in the client for reaching the SMTP and IMAP servers.

Alright. This is a bit hacky and manual, but there IS a way to do this.

Under /usr/share/courier/ you can put the SSL cert you want into imapd.pem.IP.IP.IP.IP (where IP.IP.IP.IP is the IP of the domain whose SSL cert you want to set up for IMAP to use.)

And Paul just released the patch for doing the same for SMTP. The place you need to drop the SSL cert is /var/qmail/control/servercert.pem.IP.IP.IP.IP .

Hacky and manual I can take in this case! Thanks for the update.

We just tried this on two Interworx servers and Outlook completely refuses to connect to the server. It doesn’t even prompt with a certificate issue. Renamed them to .old and it now uses the default certificate with the normal warning prompt.

Has this technique changed?

Hi lineman

Please could I ask when it stopped working as it’s an old post.

Also, I don’t suppose this is an issue with outlook and the IMAP folder, which needs setting to inbox by any chance.

Lastly, you might want to open a support ticket so IW could have a look perhaps

Many thanks


This is actually the first time I tried it. However, in looking at imapd.pem, it looks like that contains more than just the certificate. So maybe that’s the issue.

Hi lineman

I don’t think so to be honest.

I suppose it maybe a SHA issue ie SHA1 and not SHA2, but I doubt it.

I’m more inclined to think it might be a DNS cache or population of new records, if just recently changed, due to the no connect, therefore no cert warning or acceptance.

I could be wrong though, and have no way to test myself sorry.

Many thanks