ModernBILL And InterWorx module setup : PLEASE HELP


Does somebody has successfuly set ModernBill 5.2.x and Interworx ?

We have some problems for provisionning the interworx server through ModernBill

When the event runs ProcessPanel event I have this error in my website error log

PHP Fatal error: Call to undefined function xmlrpc_encode_request() in /xxx/yyx/ on line 202

Also when I try to manually run the command in the crontab (for automation) I have this

/usr/bin/php /xxx/yyy/zzz/modernbill/admin/sbin/runevents.php

Status: 302
X-Powered-By: PHP/5.2.0
Location: http://localhost/events.php?action=853&0=systemQueueStatus&1=&sid=e191bccceb4c452401a54f5df0a9131b842c20e1
Content-type: text/html

For sure http://localhost/events.php doesn’t exists !!!
What did you set in the interworx/server group config for the API Url ?
Did you set something like or ?

we tried all and no one uses to work

I’m sure I have forgotten something but what ???
I’ve set :

  1. Open your /path/to/mb/lib-modernbill/include/config/config.php/ file and paste the “Remote Access Hash” as shown below.
    $CONF[“remoteAccessHash”] = “f2ad7647377beb58808b8ffceff5527d4f9d4c1d”;

even if I use the MBAPI in local ???
What about this

// If you server has a firewall where the remote IP is dispatched to a
// local IP, then enter the local IP here. This will allow the events
// queue to call itself locally instead of using the primary domain.
$CONF[“localURL”] = “”;

in the main config/config.php ? is it because it is set to blank that the runevents.php returns http://localhost/events.php ?

pfff I really don’t know where to look at now :\

Any help will be really apreciated


Of course I’m talking about MB5, not the v4 version :wink:
Anybody use it ?

Hi Paul,

The biggest problem I see here is this one:

PHP Fatal error: Call to undefined function xmlrpc_encode_request() in /xxx/yyx/ on line 202

To fix that, try doing this as root:

yum install php-xmlrpc

And then restart the webserver.


Thanks Paul

Indeed I have installed the php-xmlrpc package and now it looks like it is much better, but still not working.

Now I’m sure ModernBill “talks” well with Interworx. BUT

the account isn’t provisonned in the control panel !

The events page show the ProcessPanel event as “completed”
As you can see the ProcessPanel is finished as “Completed” which should mean that MB has sent the request to Interworx and Interworx has returned no error

Where could we see the logs to find the problem ?

Maybe we have to set another account name rule for Interworx ?

Thanks for your help


Ok now it is working

For the records.

We had set the URL to interworx server like this or

But in fact ModernBill already parse the :2080 or :2443 depending on what option you choose (use secure connexion or not)

So cURL tried to go to this URL rather than

Even if we found this alone, thanks anyaway